Changing Player Model Colors TTT

Players would the issues of changing certain colors equipping a player model often times dark poop green.

I used this convar in the config file

ttt_playercolor_mode 0

But now the undertones are basically all white there no colors in any player model?

How do I achieve the player models showing their full color and not changing poop green.

  1. Which config file?
  2. If it’s server.cfg, is exec server.cfg in your autoexec.cfg?
  3. Make sure it’s not an addon doing this.

Its in my cfg/server

I’m using undefineds pointshop.

Is


exec server.cfg

in your autoexec.cfg?

No sir it is not in my autoexec.cfg

Put it there.

I will do just that, could you explain why I am putting that there though?

The server.cfg will not run unless it is executed; autoexec.cfg will run any command on server start, including executing the server.cfg, which contains the ttt_playercolor_mode convar.

Should I do a server restart or just apply it and change maps and load the server.

You can just type exec autoexec.cfg into your server console and it should change the convars. Changing ttt_playercolor_mode usually requires a map change, however.

what should i change my ttt_playercolor_mode too?

0

I did eveything, and the base playermodels are still white please resort to example pictures.

Type ttt_playercolor_mode in console and post what it says.

I typed it into my server console I got this

“ttt_playercolor_mode” = “0” ( def. “” )
game clientcmd_can_execute

I typed it into gmod console I got this

] ttt_playercolor_mode
“ttt_playercolor_mode” = “1” ( def. “” )
server_can_execute clientcmd_can_execute

In your gmod try typing ttt_playercolor_mode 0

Still needed help fixing.

These are your options copied from ttt.badking.net. Pick one, there is no “every color but green” option.

ttt_playercolor_mode (def. 1):
Sets player coloring mode. 0 = off, 1 = muted/dark colors only, 2 = select from a larger list of colors including brighter ones, 3 = fully random colors.

[editline]6th May 2014[/editline]

Also if you set it to 0 on the server it should also be 0 in game, make sure to change map if you ever update your server.cfg or autoexec.cfg

If you set it to anything other then zero you start getting weird colors like these.

Right now I’m trying to figure out how to get them to stay at 0 in game.

Is that a custom player model?