CityScript

And now begins the long, tedious task of troubleshooting.

I got rid of everything except the stuff required by the gamemode. Sam, do you have it working/could post up the list of addons you have?
Also, would the clientside addons have any effect on this? My server’s addon folder is empty except for the required stuff, but my gmod addons folder has god knows how many things in it >_>

I’m sure philxyz will fix it.

Ugh, well my srcds just broke… Soo I’m reinstalling it, I’ll tell you if I can get it to work…

I made a clean Garrysmod folder, installed CityScript, then put the required addons in. Didn’t work. So I went and removed ALL addons except counter-strike and derma, it still doesn’t work. Next up, removing the counter-strike folder -.-

Edit: Philly is on my server, we figured out that the error is a conflicting addon clientside, not server side. Time to test >_>
Double edit: Philly, could you post what addons you have installed so we know what DOESN’T conflict?

It’s working fine for me - I can join DrStealth’s server. I have neither ULX/Ulib nor Assmod on my machine.

I cleaned out my addons folder, except for derma and default sents, it still wasn’t working. I’m doing a clean install of gmod, gonna see if that works.

Edit:
Also, my server is staying up as it apparently isn’t an issue with the server, but with the client. Its under the list as Aro’s CityScript server or something similar, feel free to join. The server has only the necessary addons and the source game stuff.

Just reinstalled my srcds, testing cityscript now.

edit: Unintitled DFrame is what I’m getting. D: I have no mods installed except for simple prop protection and the basic scrds ones.

Mmmm. I just loaded it up with a clean install of gmod, I’m still having the error. I dunno what to try now…

[editline]02:53PM[/editline]

I FIGURED IT OUT! The client is missing files or something, because I decided to try it in singleplayer, copied the CityScript folder over to my singleplayer Gamemodes folder and it works fine on the server now!

[editline]03:00PM[/editline]

Ok. So now that I’ve got it working, how would I add myself as an admin?

Nice! I’ll see if it’s anything to do with AddCSLuaFile

[editline]08:08PM[/editline]

You are by default. Otherwise, there is a file called admins.lua to put steam IDs into.

It didn’t add me as an admin automatically. I went and looked at the Admin.Lua, I’m not quite sure where I would put my steam ID. I’m assuming in the Admin = {}; up top, but how would you do this? Using a table? Also, in my server console I’m getting the error
Lua Error: Timer Error: CityScript\gamemode\player_data.lua:259: attempt to index field ‘?’ <a nil value>

I took a look at it, here is the code its from



function CAKE.GetPlayerField( ply, fieldname )

    local SteamID = CAKE.FormatSteamID( ply:SteamID() );

    -- Check to see if this is a valid field
    if( CAKE.PlayerDataFields[ fieldname ] ) then
        
        return CAKE.NilFix(CAKE.PlayerData[ SteamID ][ fieldname ], "");
        
    else
    
        return "";      **<---- Line 259**
        
    end
    
end


For admins it would be


– CakeScript Generation 2
– Author: LuaBanana ( Aka Jake )
– Project Start: 5/24/2008

– admin.lua
– Admin functions. Admin concommands are in admin_cc.lua

SuperAdmins = { “STEAMID:STEAMID” };
Admins = { “STEAMID:STEAMID” };

Admins = { “STEAM_0:1_349988948etc”, “STEAM_0:074554545” }

QFT, I prob should’ve put 2 in my example. :smiley:

I may have fixed it but I’ll test it out. Files included in wrong order.

Yeah. Thanks guys. My server is up now, on either RP_Downtown_V2 or on rp_cscdesert (I love this map =P), and I have a few extra addons too. Server name is still Aro’s CityScript server, if anyone wants to join.

-SERVER DOWN-

Cool! I can’t join for a while but I will definitely do so. keep the server up and watch out for version 1.0.0 :stuck_out_tongue:

Stealth, send me an IP?

Hold on. The other addons I put in might be conflicting, I’m getting more errors. I’ll update this post with an IP when I get it working.

OK! The server is up and running, IP is: -SERVER DOWN-
Phil, I made the change to the init.lua, but have no way of testing it until my brother stops playing AoE and tries to join the server. Oh, and the addons I added weren’t the ones conflicting, it was actually something I went and changed. So addons aren’t conflicting, which is good.

Stealth try editing init.lua

change the lines shown here only



DB = {}

-- Add Client Side files
AddCSLuaFile( "shared.lua" );
AddCSLuaFile( "cl_playermenu.lua" );
AddCSLuaFile( "cl_binds.lua" );
AddCSLuaFile( "player_shared.lua" );
AddCSLuaFile( "cl_hud.lua" );
AddCSLuaFile( "cl_charactercreate.lua" );
AddCSLuaFile( "cl_init.lua" );

-- Server Includes
include( "shared.lua" ); -- Shared Functions
include( "log.lua" ); -- Logging functions
include( "error_handling.lua" ); -- Error handling functions
include( "util.lua" ); -- Functions
include( "hooks.lua" ); -- CakeScript Hook System
include( "configuration.lua" ); -- Configuration data
include( "player_data.lua" ); -- Player data functions
include( "data.lua" ); -- SQLite functionality (police-related bits from DarkRP - uses DarkRP jail positions)
include( "player_shared.lua" ); -- Shared player functions
include( "player_util.lua" ); -- Player functions
include( "admin.lua" ); -- Admin functions
include( "admin_cc.lua" ); -- Admin commands
include( "chat.lua" ); -- Chat Commands
include( "daynight.lua" ); -- Day/Night and Cloc
include( "concmd.lua" ); -- Concommands
include( "charactercreate.lua" ); -- Character Creation functions
include( "items.lua" ); -- Items system
include( "schema.lua" ); -- Schema system
include( "plugins.lua" ); -- Plugin system
include( "teams.lua" ); -- Teams system
include( "client_resources.lua" ); -- Sends files to the client
include( "animations.lua" ); -- Animations
include( "doors.lua" ); -- Doors

AntiCopy = {"atm", "storage_box", "sent_nuke_detpack", "sent_nuke_radiation", "item_prop", "token_bundle", "token_printer", "spawned_shipment", "toxic_lab", "toxic", "sent_nuke_part", "sent_nuke", "door_ram", "lockpick", "med_kit", "gmod_tool"}
NotAllowedToPickup = {}

DB.Init()


Stealth, I get dced when joining your server.

Edit: It finally worked, and when I get on I got the same error… Rawr.