Class maker

Okay guys, i made a class and when i restarted my server…there were no classes, and i was some stone guy…and all the shit was broken…

here was the code i put

TEAM_Lagoon Co. Owner = AddExtraTeam(“Lagoon Co. Owner”, Color(225, 0, 6), “models/player/nailgunner/slow.mdl”,
[[Owner of the Lagoon Co.]], {“weapon_umbrella_m4a1”},
“Lagoon Co. Owner”, 1, 100. 0, false)

Well lets start.
TEAM_Lagoon Co. Owner = (How do you think this is gonna work?) TEAM_Lagoon is variable yea, but what the fuck will you think lua will think of Co. ? and Owner = at last. )
Make it TEAM_Lagoon_Co_Owner = for the fucks sake.
Next; [[Owner of the Lagoon Co.]], what is this? I don’t even–ALL HAIL DARKRP.
I don’t know how that works as i don’t see code, and i don’t want to dig in shit so thats up to you to find out.

[[ This is a string ]]

Just dont use a class maker, most of them either dont work or are made for an older version of DarkRP (In other words they’re outdated). Look at the other jobs in the file its not hard. There’s also a gmod wiki that entails all this and other concepts related to DarkRP.

nonono i coded it in the shared lua folder…

[editline]17th October 2010[/editline]

uhmm the [[owner of lagoon co.]] is the description…but thanks for helping…im going to try the team lagoon thing

[editline]17th October 2010[/editline]

Im sorry…what do you mean?

[editline]17th October 2010[/editline]

Bump…i really need to know how to make a class…like fast

There are way to many people on these forums that neglect to look in the console for errors that may have occurred during loading. The error messages are usually helpful. Also, post your current code using [noparse][lua][/lua][/noparse] tags.

I assume your doing this for DarkRP, basically just add this into the bottom of the shared.lua file :slight_smile:
Tell me if anything goes wrong

TEAM_LAGOON = AddExtraTeam(“Lagoon Co. Owner”, Color(255, 0, 6, 255), “models/player/nailgunner/slow.mdl”, [[Owner of the Lagoon Co.]], {“weapon_umbrella_m4a1”}, lagoon", 1, 100, 0, false, false)

Nope lol

Can someone give me an example of a code that worked for them?

ooh and btw my code went like this (code format)

[lua] TEAM_Lagoon Co. Owner = AddExtraTeam(“Lagoon Co. Owner”, Color(225, 0, 6), “models/player/nailgunner/slow.mdl”,
[[Owner of the Lagoon Co.]], {“weapon_umbrella_m4a1”},
“Lagoon Co. Owner”, 1, 100. 0, false) [/lua]

http://darkrp.megagamer.net/kit/index.php?i=classmaker

Let’s just ignore what everyone else is saying!

Change TEAM_Lagoon Co.Owner to TEAM_Lagoon_Co_Owner

Thats not gonna work. I tride. TEAM_(Command) Thats the Job Command!

[lua]
TEAM_LAGOON = AddExtraTeam(“Lagoon Co. Owner”, Color(225, 0, 6,255), “models/player/nailgunner/slow.mdl”, [[Owner of the Lagoon Co.]], {“weapon_umbrella_m4a1”}, “lagoon”, 1, 100 0, false)
[/lua]

lol, isn’t that just exactly the same as mine except in a nice format, also how do you do that format :slight_smile:

You forgot to start the string in lagoon:

you put: lagoon"

instead of: “lagoon”

Oh, my mistake, hopefully yours will work then for him

Thanks for pointing itout aswell, I failed :stuck_out_tongue:

Okay.

If it still doesn’t work, I’m 99% sure this will work. :
[lua]
TEAM_LAGOONCOOWNER = AddExtraTeam(“Lagoon Co. Owner”, Color(225, 0, 6, 255), “models/player/nailgunner/slow.mdl”,
[[Owner of the Lagoon Co.]], {“weapon_umbrella_m4a1”},
“lagooncoowner”, 1, 100. 0, false)
[/lua]

Although it was a looong time ago I made jobs for DarkRP.

You forgot a comma there.

Ah, so did I, as the OP did:

[lua]
TEAM_LAGOON = AddExtraTeam(“Lagoon Co. Owner”, Color(225, 0, 6,255), “models/player/nailgunner/slow.mdl”, [[Owner of the Lagoon Co.]], {“weapon_umbrella_m4a1”}, “lagoon”, 1, 100, 0, false)
[/lua]