Client not updating to the most recent version

I’ve sometimes seen that I can’t see the official server, so I tried to start my own. I found out that the server was last updated today (The 22nd), while the client had last been updated the 21st, so I get “Client has incompatible version, disconnecting”. Yes, before anyone posts, I’ve tried verifying the integrity of Rust and re-installing it entirely. Any ideas? Is there any way to get a previous version of the server from SteamCMD?

http://puu.sh/b47Ex/dba133ad51.jpg

updating to the latest Rust branch should let you get onto the servers (which run off the same branch) http://files.facepunch.com/garry/26_ZLt.mp4