Client Timed out....

I can’t play online because every 40-130 seconds I get a client timed out error. It happens on ANY server I join and is annoying as hell. I am considering selling my game. I have tried changing the rate, cl_updaterate 30, and more.

nothing works… Any ideas?

join my server while noone is on. I haven’t had a ping over eighty in a long time. so you probably won’t get kicked off of it for that reason. If you still get kicked off. I might be able to help you through steam.

server ip: 87.212.108.75:29500

Hey, i have been having a similar problem which i just noticed today. worst part is it happens even when i host the multiplayer server… single player is fine of course.

that’s strange. maybe gmod is blocked in your firewall? try making an exception for gmod and then try to connect again.

I would be inclined to agree with you… if i had a firewall up. The only thing that would be blocking is my modem, which hasnt had any settings changed in a long time.

Restart steam.

you know i never thought of that… its working now… thanks for the completely obvious, make me feel stupid help!

edit i lied, timed me out after 10min instead of 1

Well my computer has taken several reboots since and the problem still exist. I am taken my firewall down completely norton 2010. I am miffed at what the problem might be. I would say i is the router, but my laptop plays it just fine.

I am quite determined that the issue lies in steam. However, in the past 4-5 years where this problem has been posted in forums, there was never a definitive answer.

edit one thing i did notice, is that if i restart steam and run gmod and dont minimize or use the overlay it wont time out. But after i do it times out, and if i join a new game it will time out in under a minute.

if only that worked for me…

quick update, it will time me out after awhile, it just takes longer when i dont minimize. think i played for 10-20 minutes

You can check if the ports are open using http://www.canyouseeme.org/.

i had a friend over who could play just fine, and people can still join me when i host

Did you check if the required ports are open?

Get out of steam, delete ‘clientregistry.blob’
it lies in somewhere like C:/Program Files/Steam

ports are forwarded, as i stated before people can join my servers. tried the clientregistry thingy, and it might of worked for 10 minutes.

Snip-
Fuck why was this thread just in popular threads right now if its from 2010

Ya, i know. The problem just started to happen today. No one knows why the fuck Steam/Garry’s Mod would do this to us! Y U NO WORK?!


(User was banned for this post ("meme reply" - postal))