Clients not downloading items

I’m creating a hud like csgo and i’m running into a weird problem. All clients aren’t downloading images



if SERVER then
	AddCSLuaFile("csgo_hud/cl_main.lua")
	AddCSLuaFile("csgo_hud/cl_mag.lua")
	AddCSLuaFile("csgo_hud/cl_weapon.lua")

	resource.AddFile("resource/fonts/stratum2_med.ttf")
	resource.AddFile("materials/csgo_hud/alert.png")
	resource.AddFile("materials/csgo_hud/armor_icon.png")
	resource.AddFile("materials/csgo_hud/bullet.png")
	resource.AddFile("materials/csgo_hud/cs2_binnoc.png")
	resource.AddFile("materials/csgo_hud/cs2_crowbar.png")
	resource.AddFile("materials/csgo_hud/cs2_defuse.png")
	resource.AddFile("materials/csgo_hud/cs2_dna.png")
	resource.AddFile("materials/csgo_hud/cs2_duck.png")
	resource.AddFile("materials/csgo_hud/cs2_eye.png")
	resource.AddFile("materials/csgo_hud/cs2_flaregun.png")
	resource.AddFile("materials/csgo_hud/cs2_magneto.png")
	resource.AddFile("materials/csgo_hud/cs2_newton.png")
	resource.AddFile("materials/csgo_hud/cs2_polter.png")
	resource.AddFile("materials/csgo_hud/cs2_radio.png")
	resource.AddFile("materials/csgo_hud/cs2_teleport.png")
	resource.AddFile("materials/csgo_hud/firemode.png")
	resource.AddFile("materials/csgo_hud/health_symbol.png")
	resource.AddFile("materials/csgo_hud/killicon.png")
	resource.AddFile("materials/csgo_hud/running_man.png")

	hook.Add("PlayerDeath", "killcounter", function(victim, inflictor, attacker)
		if not IsValid(attacker) then return end

		if attacker:IsPlayer() and attacker:IsActiveTraitor() then
			if victim:IsActiveTraitor() then return end
			attacker:SetNWInt("TKills", attacker:GetNWInt("TKills") + 1)
		end
	end)

	hook.Add("TTTBeginRound", "killreset", function()
		for k, v in pairs(player.GetAll()) do
			v:SetNWInt("TKills", 0)
		end
	end)

elseif CLIENT then
	csgo_hud = {}
	local function load()
		include("csgo_hud/cl_main.lua")
		include("csgo_hud/cl_mag.lua"))
		include("csgo_hud/cl_weapon.lua")
	end
	if GAMEMODE_LOADED then
		load()
	else
		hook.Add("PostGamemodeLoaded", "csgo_hud_Initialize", function() load() end)
	end
end


i’ve checked all the file names and there are correct
please help

that hook is done incorrectly. Its just
[lua]
hook.Add(“Hook where son?”, “What we callin this bad boy”, load)
[/lua]

As for the file not downloading correctly not sure. I just run my addcsluafile and include into a shared autorun file.

The hook runs fine btw