Collision mesh for tunnel model not hollow

Okay, so I’ve been trying to make a tunnel model for a Gmod map, so I made this as the collision mesh for it in Blender:

However, after compiling it, it’s like this in-game and I cannot walk inside it or place any props inside it, as it is “blocked”:

I’ve made sure there aren’t any double vertices and that my QC file has $concave and $maxconvexpieces 1024, and run studiomdl with -fullcollide. However, it still does not fix the problem. Any idea what’s going on here?

You smooth shaded it right?

How did you apply the smoothing groups to each piece ? Don’t forget that you can’t have two pieces with the same smoothing group number.

Blender does it differently. I’m curious on how to do it too, I’ve never managed to do it myself without exporting to Max first.

Should help you out.

Steps:

That’s all really.

Perfect, thank you guys! It seems the problem was that I was setting all of the objects to Smooth Shading at once, when I really had to set them one by one. Setting them to smooth shading one by one did the trick. Again, thank you so much for the help guys!