collision model problems

I have spent hours (sad) trying to get a good collision model for my prop.

I use softimage mod tool and I have the valvesource addon for it. No matter how I do the collision model it always comes out like this:

http://img3.imageshack.us/img3/5243/phymodel.png

Basically I need the curve and the side leading up from the curve to be as smooth as possible, the rest doesn’t really matter.

if you want to know what its for…see my vid:

Now, I don’t know what I’m talking about, and this probably is no help. But have you tried modeling it like this? As separate objects(ignore the red)
Your object has a concave shape, and I don’t think source likes those. That’s probably why it connects the bottom right part to the top right part.

http://filesmelt.com/downloader/abc.PNG

yes…and it still comes out how like my post, nothing I do changes it

Have you read this?

Looks like it says you need to model it the way I suggested and include the “$concave” where it needs to be included.

Modeling is pretty pointless if you can’t use what you make the way you made it, I think I died a little inside.

Just make a quick collision model. 5 simple blocks would work in this situation.

Just do following:

  1. press 8
  2. click on the “plus”-icon next to one of your objects
  3. double click on geometry approximation
  4. answer with “no”
  5. click on the polygon mesh tab
  6. disable automatic discontinuity
  7. export as phys smd
  8. add $concave and $maxconvexpieces “50” to the qc
  9. compile
  10. profit

Also don’t forget to apply a texture to your collision mesh but don’t waste your time to uv it nicely because the CM is invisible all the time.