$color has failed me

http://luaforfood.com/dirtypics/hovercar_colorfail.JPG

The game I’m porting this model from set the tint of the hovercar to a variety of presets using one base texture as seen above, inside the game itself (dynamically generated).

I planned to use $color to do this/save file size, but no matter where I put it in the material, nothing happens.



"VertexLitGeneric"
{
	"$baseTexture" "models/cithub/HoverCar01_Diff"
	"$bumpmap" "models/cithub/HoverCar01_Norm"
	"$color" "[1 0 0]" // testing
}


I’ve verified it’s the right material, model viewer reloads the material properly etc.

Anyone?

From what I can see, I don’t think you’re supposed to put $color in quotations, as it’s not a loading sequence.

Not entirely sure, but it’s my best guess.
Have you tried using it as RBG code? As in, 255, 255, 255.

Tried with and without quotes, and yes, tried with standard RGB in both square and curly brackets as per the VDC entry

I have no real suggestion then.
The last I have would be to just lay a slight tint over the material with GIMP or Photoshop or something. I didn’t even know of $color.

Although it seems to me that the model already is slightly red tinted, but I don’t know if it were like that originally.

Yeah, it was like that originally.

Anything else I can do to scale color in the vmt?

Still got nowhere. I know the parameter works because I used it in a gamemode before for an UnlitGeneric HUD element

I have been looking for some code like this for my Halo 3 players, but have been unsuccessful.

I could only ever get $color values working back on my old FX5600.

Hmm, maybe a directX issue?

IIRC DX9 uses a different shader parameter.

Try doing it like


"$color2" "{0 0 0}"

That’s how it looks in a .vmt from Team Fortress 2.

You’re a deity to me

http://filesmelt.com/dl/hovercar_yay.png