Combine Bunker Gun

Before you say search or something, it says I don’t have permission for some reason.

Whenever I make a bunker gun (Combine Turret) in a map, in Garry’s Mod it ends up ‘spazzing’ and doesn’t shoot.
I’ve also tried other prefabs with the same result. They all work fine in EP2.

I’m using Engine 2009 and HL2: Ep2. I tried it with Regular HL2 also. Tried unmounting EP2 and EP1.

A lot of scripted stuff just won’t work in Garry’s Mod. Which is why characters will assume the T-pose when they’re meant to perform scripted sequences and that sort of thing.

I tried the bunker gun with the same results, although it worked fine in EP2.

There used to be a combine onslaught map where you could spawn combine bunker guns on toybox.
I’m not sure if it’s still there but you could probably just search for it and see for your self if they still work or if they too are broken. I remember them working fine.

There is also the old electric onslaught map that also had working combine guns.

I’ll look those up, thanks!