"Combining" VTF's?

Hello, as my title says, I would require help “combining” VTF files.

I have a playermodel that had bodygroups, and I in 3dmax made it so that the model has those certain bodygroups attached to it, and deleted the useless ones. Problem is now, I do not know how I can combine the texture files (.tga atm) so they do not appear as texture errors.
It’s a hazmat suit with a gasmask bodygroup that I put in to the model now permantently, but can’t figure how I can combine vtf or the texture files so it applies to the whole body as the gasmask is not a different mdl anymore.

I am not sure if this is the way to do it or if it has to be done in the .qc or somewhere else, I am pretty new to this but I’ve learned very quickly.

Don’t quite understand what the problem is, So you’ve edited a model and when you view it in-game there’s missing textures?

Can I see images of the problem please?

Sounds like a mistake with the UV map, but yeah, could you post a picture of the problem? From what you describe, I assume one part of the texture is applied to one part of the model but not the rest?

As ExplosiveCheese said, it may be a UV problem. When you changed the model to permanently include those bodygroups, the model’s texture coordinates changed to accommodate the bodygroups’ textures.

If you are compiling in the Source Engine, what you could so is simply go into the QC of the model, and change the bodygroups section.

Say the model had 3 different sets of pouches in one bodygroup category. Normally, it would look like this:


$bodygroup "pouches"
{
	studio "Pouches_1.smd"
	studio "Pouches_2.smd"
	studio "Pouches_3.smd"
	blank
}

This means that you can alternate between the 3 different pouches, and also have no pouches when set to “blank”. To force the model to only use 1 bodygroup all the time, thus not allowing you to switch between any of the other options, you would replace the above section with this:


$bodygroup "pouches"
{
	studio "Pouches_1.smd"
}

Since there are no other sections other than “Pouches_1.smd”, it will always use that as part of the model. This will have the exact same effect as what you are trying to do without messing up the UV or having to actually edit the model itself (AKA, save you a lot of time).

Thank you alot, this worked nicely!
I apologize for my grammer and typing on the first post, I was a bit tired I suppose.
But I thank you a lot and everyone who tried to help!