Compile two reference SMDs

Hi!

I’m attempting to compile this station (http://img689.imageshack.us/img689/4805/station1c.jpg) – and I’ve reached 50,868 polys. I hear the limit is 26,000ish.

Each time I attempt to compile, I get this:

Working on “file.qc”
SMD MODEL station_1.smd
ERROR: too many indices in source: “station_1.smd”
ERROR: Aborted Processing on ‘retrobox\station_1.mdl’
WARNING: Leaking 1 elements

I read here (http://www.facepunch.com/showpost.php?p=9785995&postcount=6) that you can split the SMD into two and refer to it with another $model/$body command. I’m not sure how that works.

Is there any way someone can clear this up for me? Here is my QC:


$modelname "retrobox\station_1.mdl"
$body mybody "station_1.smd"
$staticprop
$surfaceprop combine_metal
$cdmaterials "models\retrobox"
$sequence idle "station_1.smd" loop fps 15
$collisionmodel "station_1_collision.smd" { $concave }


Why is it that big?

I’ve made some progress. I managed to reduce it to 16,096 polygons. However, I’m now running into problems with the collide model.

I’m still getting the error:

WARNING: Error with convex elements of station_awesome_col.smd, building single convex!!!
Model has 7 convex sub-parts

Here is my collide model:

http://img6.imageshack.us/img6/3514/colzx.jpg

Since it is a space station, I need ships to be able to fly into the hangar area. Or, at least, out of it. Each piece is in a seperate smoothing group, I’ve set GUIStudioMDL to full collide, and even have $maxconvexpieces 30 set up in my qc file.

Does anyone have any idea?

EDIT: I’ve actually gotten it to work once before, by setting the smoothing groups, but I needed to change the dimensions of some of the boxes in my collide and now it doesn’t want to compile correctly anymore. I even took out a box, but still no go.