Compiled model shows up as a effect and is invisble

I need help with this, and is my first attempt compiling.

Basicly, my model, which is a jet airplane, which turns out as a effect and is invisible in game.

My QC:


$modelname "boeing\b737con.mdl"
$cdmaterials "boeing\"

$scale 600
$surfaceprop "metal"

$sequence idle "Boeing_737.smd" fps 1

$collisionmodel "Boeing_737.smd" {
$mass 50.0
$inertia 1.00
$damping 0.00
$rotdamping 0.00
}


My compile log:


GUIStudioMDL 2.2/Source - © 2007 Neil 'Jed' Jedrzejewski - http://www.wunderboy.org/

Added game config - "Garry's Mod"

Loaded QC file - "E:\Documents and Settings\oliver\My Documents\source 737\Source 737\737.qc"

Created command line: "E:\Program Files\Steam\steamapps\oscar1004\sourcesdk\bin\orangebox\bin\studiomdl.exe" -game "E:\Program Files\Steam\steamapps\oscar1004\garrysmod\garrysmod" -nop4 -nox360 "E:\Documents and Settings\oliver\My Documents\source 737\Source 737\737.qc"

qdir:    "e:\documents and settings\oliver\my documents\source 737\source 737\"
gamedir: "E:\Program Files\Steam\steamapps\oscar1004\garrysmod\garrysmod\"
g_path:  "E:\Documents and Settings\oliver\My Documents\source 737\Source 737\737.qc"
Building binary model files...
Working on "737.qc"
SMD MODEL Boeing_737.smd
Collision model completed.
---------------------
writing E:\Program Files\Steam\steamapps\oscar1004\garrysmod\garrysmod\models/boeing\b737con.mdl:
bones          676 bytes (0)
animations     112 bytes (1 anims) (1 frames) [0:01]
sequences      216 bytes (1 seq) 
ik/pose          0 bytes
textures         4 bytes
keyvalues        0 bytes
bone transforms        0 bytes
collision        0 bytes
total         1044

Completed "737.qc"


Its my first apptempt at compiling and its really fucked up at the moment.

Any tips?

Looks like something went wrong exporting the .smd. Try exporting again, and if the .smd size is really small (~1kb), you might’ve messed up something in the export process.

No, no. You have to export different smd files for different purposes. You’ll want to export one reference .smd and then one sequence .smd, for the idle animation.
You need this line:



$model "studio" nameofyourreference.smd


Then, the sequence line should be:



$sequence idle nameofyoursequence.smd" fps 1


And your collision model line should use the reference .smd, unless you want to make your own collision model. In that case, you’d have to export another simpler .smd (as a reference .smd) and tell $collisionmodel to use that one.

Now It doesnt create a phy file, still invisble.