***** Compiler problems ->vvis.exe and vrad.exe

Hello! fellow mappers im new here to the forums and i have been browsing for years. enough of me now i have a problem that rather annoying. and i quite frankly need help with.

my new map im working on called RP_harbor. i cannot get lights or water into my map. i looked there is no leaks, nor any entity out side of the map.

every time i run the compiler “run map” with settings on normal and no HDR.
it freezes everytime on vvis.exe or vrad.exe. i understand these are critical events for hammer to compile and run the map.

HELP! if you need more detail to the problem let me know i can explain further.




** Executing...
** Command: "c:\program files (x86)\steam\steamapps\ktr_19\sourcesdk\bin\ep1\bin\vbsp.exe"
** Parameters: -game "c:\program files (x86)\steam\steamapps\ktr_19\half-life 2\hl2" "C:\Users\Cindy\Desktop\rp_harbor\maps\rp_Harbor"

Valve Software - vbsp.exe (Dec 11 2006)
4 threads
materialPath: c:\program files (x86)\steam\steamapps\ktr_19\half-life 2\hl2\materials
Loading C:\Users\Cindy\Desktop\rp_harbor\maps\rp_Harbor.vmf
fixing up env_cubemap materials on brush sides...
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (1)
Processing areas...done (0)
Building Faces...done (0)
Chop Details...done (0)
Find Visible Detail Sides...
Merged 28 detail faces...done (0)
Merging details...done (0)
FixTjuncs...
PruneNodes...
WriteBSP...
done (0)
writing C:\Users\Cindy\Desktop\rp_harbor\maps\rp_Harbor.prt...done (0)
Creating default cubemaps for env_cubemap using skybox materials:
skybox/sky_day01_08*.vmt
Run buildcubemaps in the engine to get the correct cube maps.

No such variable "$hdrbasetexture" for material "skybox/sky_day01_08rt"
Can't load skybox file skybox/sky_day01_08 to build the default cubemap!
Finding displacement neighbors...
Finding lightmap sample positions...
Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
Building Physics collision data...
done (0) (74341 bytes)
Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
Water found with no water_lod_control entity, creating a default one.
Compacting texture/material tables...
Reduced 393 texinfos to 231
Reduced 51 texdatas to 42 (1717 bytes to 1437)
Writing C:\Users\Cindy\Desktop\rp_harbor\maps\rp_Harbor.bsp
1 second elapsed

** Executing...
** Command: "c:\program files (x86)\steam\steamapps\ktr_19\sourcesdk\bin\ep1\bin\vvis.exe"
** Parameters: -game "c:\program files (x86)\steam\steamapps\ktr_19\half-life 2\hl2" "C:\Users\Cindy\Desktop\rp_harbor\maps\rp_Harbor"


** Executing...
** Command: "c:\program files (x86)\steam\steamapps\ktr_19\sourcesdk\bin\ep1\bin\vrad.exe"
** Parameters:  -game "c:\program files (x86)\steam\steamapps\ktr_19\half-life 2\hl2" "C:\Users\Cindy\Desktop\rp_harbor\maps\rp_Harbor"


** Executing...
** Command: Copy File
** Parameters: "C:\Users\Cindy\Desktop\rp_harbor\maps\rp_Harbor.bsp" "c:\program files (x86)\steam\steamapps\ktr_19\half-life 2\hl2\maps\rp_Harbor.bsp"


http://optimization.interlopers.net/

Read this, it should help you fix your map.

Try optimizing your map for vvis?
http://optimization.interlopers.net/

Looks like you aren’t running vvis or vrad.

[editline]04:14PM[/editline]

Fucking ninja’d :ninja:

http://optimization.interlopers.net/

:firstpost:

You can’t have spaces in your map name. Otherwhise VBSP takes a crap on VRAD and VVIS.

Lol, dumbs :downs:

Forum bug causes the space.

Alright thx guys ill take a look at these suggestions and ill post up my results here in a bit


Okay, i pretty much looked into optimizing my level. there’s really not much i can optimize on. given for how much i have now.
i checked to see if any brushes were overlapping and that’s not the case, esp with the water.

i renamed my map from RP_Harbor to RPHarbor, and i ran that. Vvis and vrad are still freezing.

now, im not sure if it still works when it freezes or not, all i know is that the compiler stops responding forceing me to endtask vvis and vrad.

did i mention that i am running windows 7 64 bit? could there be an issue with that?



** Executing...
** Command: "c:\program files (x86)\steam\steamapps\ktr_19\sourcesdk\bin\ep1\bin\vbsp.exe"
** Parameters: -game "c:\program files (x86)\steam\steamapps\ktr_19\half-life 2\hl2" "C:\Users\Cindy\Desktop\rp_harbor\maps\RPHarbor"

Valve Software - vbsp.exe (Dec 11 2006)
4 threads
materialPath: c:\program files (x86)\steam\steamapps\ktr_19\half-life 2\hl2\materials
Loading C:\Users\Cindy\Desktop\rp_harbor\maps\RPHarbor.vmf
fixing up env_cubemap materials on brush sides...
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (0)
ProcessBlock_Thread: 0...1...2...3...4...5...6...7...8...9...10 (1)
Processing areas...done (0)
Building Faces...done (0)
Chop Details...done (0)
Find Visible Detail Sides...
Merged 28 detail faces...done (0)
Merging details...done (0)
FixTjuncs...
PruneNodes...
WriteBSP...
done (0)
writing C:\Users\Cindy\Desktop\rp_harbor\maps\RPHarbor.prt...done (0)
Creating default cubemaps for env_cubemap using skybox materials:
skybox/sky_day01_08*.vmt
Run buildcubemaps in the engine to get the correct cube maps.

No such variable "$hdrbasetexture" for material "skybox/sky_day01_08rt"
Can't load skybox file skybox/sky_day01_08 to build the default cubemap!
Finding displacement neighbors...
Finding lightmap sample positions...
Displacement Alpha : 0...1...2...3...4...5...6...7...8...9...10
Building Physics collision data...
done (0) (73917 bytes)
Placing detail props : 0...1...2...3...4...5...6...7...8...9...10
Water found with no water_lod_control entity, creating a default one.
Compacting texture/material tables...
Reduced 393 texinfos to 231
Reduced 51 texdatas to 42 (1700 bytes to 1422)
Writing C:\Users\Cindy\Desktop\rp_harbor\maps\RPHarbor.bsp
1 second elapsed

** Executing...
** Command: "c:\program files (x86)\steam\steamapps\ktr_19\sourcesdk\bin\ep1\bin\vvis.exe"
** Parameters: -game "c:\program files (x86)\steam\steamapps\ktr_19\half-life 2\hl2" "C:\Users\Cindy\Desktop\rp_harbor\maps\RPHarbor"

Valve Software - vvis.exe (Nov  8 2007)
4 threads
reading c:\users\cindy\desktop\rp_harbor\maps\RPHarbor.bsp
reading c:\users\cindy\desktop\rp_harbor\maps\RPHarbor.prt
1031 portalclusters
2737 numportals
BasePortalVis:       0...1...2...3...4...5...6...7...8...9...10 (0)
PortalFlow:          0...1...2...3...4...
** Executing...
** Command: "c:\program files (x86)\steam\steamapps\ktr_19\sourcesdk\bin\ep1\bin\vrad.exe"
** Parameters:  -game "c:\program files (x86)\steam\steamapps\ktr_19\half-life 2\hl2" "C:\Users\Cindy\Desktop\rp_harbor\maps\RPHarbor"

Valve Software - vrad.exe SSE (Nov  8 2007)
----- Radiosity Simulator ----
4 threads
[Reading texlights from 'lights.rad']
[45 texlights parsed from 'lights.rad']

Loading c:\users\cindy\desktop\rp_harbor\maps\RPHarbor.bsp
No vis information, direct lighting only.
7716 faces
9109864 square feet [1311820416.00 square inches]
2 displacements
16498 square feet [2375730.00 square inches]
17 direct lights
BuildFacelights:     0..
** Executing...
** Command: Copy File
** Parameters: "C:\Users\Cindy\Desktop\rp_harbor\maps\RPHarbor.bsp" "c:\program files (x86)\steam\steamapps\ktr_19\half-life 2\hl2\maps\RPHarbor.bsp"


Optimize it more, or wait longer. Huge ass maps


9109864 square feet [1311820416.00 square inches]


take forever to compile.

Or you could maybe not make the map so big.

Right, the basic explanation is windows is a bit retarded, when a program is really busy, the OS thinks it’s ignoring it and reports it as dead. VVis and VRad are both cpu intensive tasks due to the large amount of complex math and thus the operating system think they’re stuck in an infinite loop or similar.
tl;dr Basically just let them run, they aren’t dead.

haha alright, the perhaps its not really a problem other then my map is huge. i was googling around come to find that this is my problem.

thx guys!!!

now does any one have any good tut sites for space maps??