Completely disable player colors in gamemode

I tried setting the player color to 0,0,0 and 1,1,1 but that’s just black & white.

I want every player in my gamemode to not have any player model color, so all combine soldiers have the classic blue eyes, elites have red eyes, rebels look normal etc.

Make your own player class.

player_manager.RegisterClass

Tried player classes before, didn’t work. I did everything as in the tutorial. Right now I’m using a class system by setting their walk speed, run speed, weapons etc. from a classes table, would that work?

They work, how exactly were you setting them?

I copied and pasted the class template. I didn’t even touch it (to make sure it worked). Then I included the file and AddCSLuaFile’d the file in shared.lua, then I used player_manager.SetPlayerClass to set the class in the spawn function. I messed with it for hours and it just wouldn’t work, no errors or anything, and yes the file was being loaded.

okay, i got player classes to work, now what?