con_filter_text query.

So, I’m trying to filter out

“Too many vertex format changes in frame, whole world not rendered”

from the console, yet no matter what I set con_filter_text to it filters out a lot of information.
Yes, it does filter out “Too many vertex format changes in frame, whole world not rendered” successfully, however it also removes a few /n characters as well as removing command output

for example with con_filter_enable = 1 I tried typing con_filter_enable to get the standard help output, but you get nothing. In general it messed up a lot of console output.

So, any idea why?

[editline]3rd December 2011[/editline]

-edit

For example


iRIDEsisters slayed Grendpa(( ByB@ | Pantho: this has an insane zoom for the firing time )) Type /dropmoney <Amount> to drop money on the floor.(( ByB@ | Pantho: i broke the sound script, bleh )) (( iRIDEsisters: lol )) (( Geoff Robertson: Why can't I have those guns? )) (( ByB@ | Pantho: we don't love you )) (( ByB@ | Pantho: why you no die )) ] retry



Will eventually time you out due to character lenght, seems weird.
Also tried doing con_filter_text = “vertex”.
But no matter what text is set to results in the same /n removal.

Have you tried disabling multicore rendering? It tends to cause issues with console output.

Afaik there was a start parameter to filter console text too.

Probably the same, and we where forcing it to clients to get rid of the vertex error spam crap.

[editline]3rd December 2011[/editline]

Yes, no effect.

I have this in my autoexec.


con_filter_enable 1
con_filter_text_out Too many vertex format changes in frame, whole world not rendered

No problems thus far.

try typing something in chat
then again
then again
check console

Or try typing net_graph or any command you can see output on.

No problems here, chief. From the sounds of it, you’re not using con_filter_text_out.

indeed, I was not using out :slight_smile: