Configuring CS:GO Hammer for Garry's Mod

CS:GO version of Hammer appears to be more complete and stable so I decided to use it for Garry’s Mod mapping. But I ran into some problems configuring it.
I tried to add additional game “gmod” into GameConfig.txt and point to new mod directory as it used to be in Source SDK.
It worked, hammer appears to be mounting all the stuff but all the content except bundled with hammer ones is still missing.
Hammer messages:

https://vixen.nxserv.eu/owncloud/index.php/s/MHEGv8BCmTyj5AY/download

Note: ignore error on second line, I tried to add -game “gmod” to it
GameConfig.txt
I’ve set up directory tree like this



G:\games\Steam\steamapps\common\Counter-Strike Global Offensive\gmod\
    gameinfo.txt
    addons\
        content\
            materials
            models
        content2...


gameinfo.txt
Thanks for helping

You cant use csgo’s hammer for making gmod maps. Cs:go and gmod are on entirely different engine versions meaning the compiler produces a bsp gmod cant load.

If you use the old compile tools I think even the .vmf versions differ and thus wont be compiled properly.

[editline]26th February 2016[/editline]

Also I don’t get this. I map for ep2 and hammer hasn’t crashed in ages for me.

I meant only hammer, I didn’t meant the compiler set.
For compiling I use Source SDK2013 Multiplayer’s compiler set. I used SDK2013’s hammer which was a bit unstable. I had some crashes on accidently selecting emty space in 3d view.

  • Also SDK2013’s hammer is missing WorldVertexTransition $blendmodulatetexture support in 3d view.

Just use the “Source SDK” tool from the tool menu.

Fuck using all these other “Source SDK’s”
The best thing I find is just go into the Gmod directory > \Steam\steamapps\common\GarrysMod\bin
and run hammer from the folder as Admin.

Since steam pipe was added to well… Steam a few years ago, it broke the Source SDK launcher tool for so many people and it was hard to find work arounds.

Whenever I make a map I always just run hammer from the folder UNLESS I’m making a CSGO map which then I just use the launcher tool as it’s stable.

I tried to launch hammer the way laucher does “hammer.exe -nop4” and it worked but it was missing ability to mount anything from search paths. I’ll try to launch it from SDK Tool when I get home.

Nevermind, it crashes on model loading attempts.