Confused about server.cfg -- server doesn't seem to load my cvars

Hey guys,

New to hosting a TTT server; everything is running fine (friends can join, games work as expected), but we have different settings we like to use for karma etc. and it seems that no matter what I try to do with my server.cfg file, I still have to manually edit all those settings.

Here’s my valve.rc:


// load the base configuration
//exec default.cfg
//exec server.cfg
// Setup custom controller
// exec joystick.cfg

// run a user script file if present
exec autoexec.cfg
//////////////////////////////////////////
// Command line statements //
//////////////////////////////////////////
stuffcmds


And my server.cfg:


hostname "GooberGroup"
decalfrequency	"5"
log "on"
servercfgfile "server.cfg"
net_maxfilesize "35"
fps_max "1000"
exec banned_ip.cfg
exec banned_user.cfg

ttt_preptime_seconds "45"
ttt_firstpreptime "120"
ttt_traitor_pct "0.33"
ttt_detective_min_players "6"
ttt_postround_dm "1"
ttt_karma_starting "900"
ttt_karma_low_amount "650"
ttt_karma_low_ban_minutes "6"
ttt_namechange_bantime "0"
ttt_detective_hats "1"

What noob error am I making? :frowning:

[editline]8th December 2013[/editline]

Both files are in common/GarrysMod/garrysmod/cfg

//exec server.cfg is commented out.

I think that was a random change I tried just to see if it would work. If I fix that and still no dice, what else could/should I try?

[editline]8th December 2013[/editline]


Garry's Mod

terrortown
ttt_camel_v1
1
76561198018410111
Requesting 1 lua files from the server
clientside lua startup!
Lua JIT is DISABLED!
Requesting texture value from var "$dummyvar" which is not a texture value (material: NULL material)
Included TTT language file: chef.lua
Included TTT language file: english.lua
TTT Client initializing...
TTT initializing convar settings...
TTT Client post-init...
Compact freed 1290240 bytes
JOY_AXIS_X:  mapped to Turn (absolute)
JOY_AXIS_Y:  mapped to Look (absolute)
JOY_AXIS_Z:  unmapped
JOY_AXIS_R:  mapped to Forward (absolute)
JOY_AXIS_U:  mapped to Side (absolute)
JOY_AXIS_V:  unmapped
Advanced Joystick settings initialized
Server default language is:	english
Redownloading all lightmaps


That’s what comes up when I start the server

Are you creating your server using Start New Game in main menu? I don’t think GSP provides you acces to anything outside of GarrysMod/ folder.

Yes. So do I need to move files around, or just find a different way of starting the server?

Just type “exec server.cfg” into your console, or into autoexec.cfg.

Oh, I see. I suppose I’ll still have to do this every time? Still easier than entering every variable, though.

You gotta enter it every time in console, or put it once into autoexec.cfg

Just put exec server.cfg in your autoexec.cfg