Confused with server, whats wrong?

I’m having some trouble with trying to get people to download models on my server,

The models were placed in 2 directories at different times, one after another:

Once in their directories and another time in addons

I have tried using the commands



resource.AddSingleFile("models/grimreaper/grimreaper.dx80.vtx")
resource.AddSingleFile("addons/slowmodels/models/grimreaper/grimreaper.dx80.vtx")
resource.AddFile("models/grimreaper/grimreaper.dx80.vtx")
resource.AddFile("addons/slowmodels/models/grimreaper/grimreaper.dx80.vtx")
resource.AddSingleFile("slowmodels/grimreaper/grimreaper.dx80.vtx")
resource.AddFile("slowmodels/grimreaper/grimreaper.dx80.vtx")


I have tried placing them in both /lua/autorun/server
and gamemode…/init.lua

I am running pointshop and trying to add new trails and player models to it, it seems that when I attempted to add Catwomen, the model would appear black/purple as if the material was missing, no one was being forced to download the material when they joined, when i added the pack to my addons folder, the material works but only for me.

However, when adding a Pedobear trail to the server, the material was being downloaded however still showed up purple/black.
I don’t know why this is happening, the resource.AddFile/resource.AddSingleFile only seem to work for some things, it works for resource.AddSingleFile("/sound/ttt/traitorwin.mp3") but not for resource.AddSingleFile(“models/grimreaper/grimreaper.dx80.vtx”)