Connection failed after 4 retries?

Any server I try to connect to ends up showing this error. It might be a steam error, but I don’t really know.

Try reinstalling GMOD

Doesnt help, I believe it may be a firewall problem, because it started happening after I uninstalled my old firewall program.

So far, I have tried:

Deleting ClientRegistry.blob

Reinstalling gmod (didn’t delete the whole folder for it, just did Delete Local Content)

Reinstalling Steam

Making sure its allowed in firewall

I’m on a different wifi network now, I’m going to try again in a minute

[editline]14th September 2013[/editline]

Alright, so its definetly a problem with my home router/modem, because it worked here. Maybe I need to forward some ports or something

Make sure UPnP is enable on your modem/router.

Allow steam & srcds into your firewall “C:\Program Files (x86)\Steam\SteamApps\NAME\garrysmod”

Make sure you have no anti-virus programs (disable them)

Get a new network cable

bump, as the problem isnt solved yet.

It is definitely a router/network problem, because I can connect to servers on any other network.