Content Upload - File already exists in the cloud

I just tried to update one of my Cloudscript Props.

I deleted the existing files, and when I tried to upload a ZIP with the new ones I get an error saying ‘(File already exists in the cloud)’

I thought it might be because it takes a while to ripple the deletes through the toybox mirrors so I left it a couple of hours but its still doing it.

What should I do? (or is this a bug?)

[editline]0[/editline]

Also, where’s the Workshop area for maps? I can’t see it in the New Game section.

I’m having the same issue. I’m trying to delete an old version of my map so that I can replace it with an update version (which uses the same file name), but it will not delete.

I ended up using a Hex Editor and renaming everything.

17 hours since I hit “delete”, and it still hasn’t deleted. I’m guessing it shouldn’t take that long.
Garry could you take a look at this?

Wouldn’t you still have to upload everything with different names to the original files? I don’t want to do that. If I upload my updated map with a different name, users who download it will continue to have the old version at the same time, and none of the toybox saves will work on the updated version. But if I can delete the old version and upload the updated version with the same name, I’m assuming existing toybox saves will continue working on it, and it will replace the old version on users machines.

Not sure, garry will have to answer that one.

I will re-add the download button - sorry.

Do you mean you’ll re-add the delete button?
If you do really mean download button, I don’t understand how that would help. Could you explain it?

I’ve done some testing, and it looks like clicking delete sends a POST to “http://toybox.garrysmod.com/content/delete/” (with “?fileid=” and the file’s ID at the end) which returns a 404 error.

I meant the delete button

Ok, deleting works now!

Thank-you

I’m still unable to delete content. I’m trying to delete file ID 29086 (maps/gm_pkmn_pallet_town.bsp[URL=“http://toybox.garrysmod.com/cloudscript/?edit=39368&tab=content#”]), and I’ve tried both with and without it included in Toybox map 39368 (gm_pkmn_pallet_town). (I want to replace the map file with an updated one with the same name). Does it take a bit of time before it actually gets deleted?

no it should delete it instantly

I’ll go through the steps of what I’ve done and describe what happens.
Address http://toybox.garrysmod.com/content/, click “Show only your files”, click “maps”, hover over “gm_pkmn_pallet_town.”, click “Delete file”, messagebox pops up saying “Are you sure? This file is being used by 1 scripts! Deleting this file might break them!”, click “OK”, file fades away, go to “Content”, “Show only your files”, “maps”, and it is still there.

I also tried removing it from the script so the “Are you sure?” box wouldn’t pop up, but that doesn’t solve it.

I also tried going directly to http://toybox.garrysmod.com/content/delete/?fileid=29086 which gives me a blank page.

It’s working for me. Try using shift +f5 to clear your cache ?

Tried that, doesn’t make a difference. I’ve been doing all this in Firefox 3.6, so I just tried it in Chrome 10 beta and IE9 RC, and it was the same in those as well. I’ll see if I can do it in the GMod Toybox tab.
Edit: Doesn’t work in the Gmod Toybox tab either.

Other than me, can everyone else delete content? Or is only Garry able to do it? Is there anything I can do to help get it working?

I’ll look into it Monday

Once the deleting function works, I’ll be able to delete my files and upload updated versions, but deleting ~70 texture files isn’t going to be quick. Rather than manually deleting the files, could you possibly make it so that when a .zip is uploaded it automatically deletes any pre-existing files with the same names (but only if those files belong to the uploading user)?

Something like this:

  • 0 files already exist; allow .zip upload
  • 1 or more files already exist, all belong to the uploader; delete existing files, allow .zip upload
  • 1 or more files already exist, 1 or more belong to other people; don’t allow .zip upload, show error

Yeah, that sounds like a plan