Could not load library client

Tried to load up Gmod for the first time today and got this error.

I was just playing yesterday, so I think it has something to do with the new update. I looked around the forum to see a fix, but found nothing.
Any solutions?

Go into your steam/steamapps/yourusername/ and rename the garrysmod folder to something else, then start it up.

Fixed. You fixed it. You. Out of the many that say the post and kept scrolling, you came. You came and saved me. Thank you. Thank you.