Could someone help me set up a skeleton gamemode?

Solved thanks to bluecrest.

This pack has a skeleton gamemode for garry’s mod 13: http://www.garrysmod.org/downloads/?a=view&id=130522

Yes, I know but I can’t manage to set it up properly for whatever reason. Do you think you could help me?

What specifically is the problem with it?

Not really sure. The gamemode doesn’t update in the server list and when I connect it says “Too many Lua errors”. IP: 178.239.170.110:27057 if you want to see for yourself.

I’m working on a dynamically loading skeleton game-mode. I actually should have it in working condition, I’ll double check it and post it up when I finish.

First put [LUA]sv_kickerrornum 0[/LUA] in your server.cfg so i can actually join.

Changes has been done.

[editline]28th June 2013[/editline]

I really just want my gamemode to launch so I can start coding, I don’t see why this don’t work so help would be appreciated.

This is your error.

[LUA]Couldn’t include file ‘development\gamemode\cl_init.lua’ (File not found) (<nowhere>)
Couldn’t Load Init Script: ‘development/gamemode/cl_init.lua’
[/LUA]

http://puu.sh/3pWWe.png

[editline]28th June 2013[/editline]

It’s right there =/

Make sure in init.lua you have [LUA]AddCSLuaFile( “cl_init.lua” )[/LUA] and not [LUA]include( “cl_init.lua” )[/LUA]

init.lua



AddCSLuaFile("cl_int.lua")
AddCSLuaFile("shared.lua")

include("shared.lua")


You have “cl_int.lua” instead of “cl_init.lua”

If this caused it I will seriously take suicide.

[editline]28th June 2013[/editline]

Same error.

My files:

init.lua



AddCSLuaFile("cl_init.lua")
AddCSLuaFile("shared.lua")

include("shared.lua")


cl_init.lua



include ("shared.lua")


shared.lua



GM.Name = "development"
GM.Author = "Fractional"
GM.Email = "N/A"
GM.Website = "N/A"

function GM:Initialize()
	self.BaseClass.Initialize(self)
end


Edit: 3:14 AM been trying to solve this for 2h+ any help is still appreciated but I am going to bed now. Thanks guys! :slight_smile:

Theres a space between include and the parenthesis in your cl_init.lua. Make sure theres no spaces and that should fix it.

This did not solve it.

[editline]28th June 2013[/editline]

Bump, could someone please add me on Skype and try to solve this for me? Would do anything for it…

You are most likely not setting your gamemode properly. To clarify, you must put +gamemode development in your command line launch options.

I don’t have a command line, I’m using a host from a website.

Your host must provide you with such functions, otherwise you won’t be able to start a server properly.

‘gamemode development’ may also be placed in cfg/autoexec.cfg or cfg/server.cfg. However, I have seen cases where errors occur when it’s not placed in autoexec.cfg for some reason.