Couldn't change active gamemode darkrp

Hey guys , can you help me? When i trying to change gamemode (sandbox to darkrp) i have this error : Couldn’t change active gamemode darkrp not found.
In folder gamemodes i have gamemode called “darkrp”
In the server.cfg i already wrote : gamemode “darkrp”
My start.bat :
[start /wait/high srcds.exe -console -game garrysmod +maxplayers 30 +map rp_downtown_v2 +fps_max 0 +mp_flashlight 1 -tickrate 66 -port 27015 +sv_lan 0 +gamemode “darkrp”]
Any solutions?

try +exec “server.cfg” instead of gamemode?

I’ve had the same problem when I first attempted setting up my own server. here’s how I fixed the issue.

@echo off
cd C:\SRCDS\Servers\Garysmod\orangebox
echo Starting game server.
echo Starting Vomere’s Server
srcds.exe -console -game garrysmod +gamemode postnukerp +map gm_atomic +maxplayers 24 -tickrate 66
echo Server has now started.

Just changed the postnukerp to darkrp and it should work fine.

Oh and just to clarify the above info is how my server launcher .Bat file was setup.