Couldn't CRC map, disconnecting

I setup a FastDL on my server, but the map gives me this CRC error every time I try to download it. I am able to access the fastdl on the website so its not website permission errors. I have been trying to find an answer but with no avail, hopefully I can get an answer here

http://images.akamai.steamusercontent.com/ugc/1470776377121238952/583748631922736510D37576168EC9EC41C90A64/

Also here is my FTP server to show its setup correct

http://puu.sh/jBSvA.png

and finally here is my server.cfg

net_maxfilesize 64
“sv_allowupload” “1”
“sv_allowdownload” “1”
“sv_downloadurl” “website.com/fastdl/garrysmod

Delete it from your download/maps folder then try

On my client or server?

Client, if it still happens reupload the map serverside

Also check if the file sizes are similar (If it’s the same file) for the map you are downloading and the map you are loading on the server

Okay now It works, but the fastDL doesn’t make it download faster arrg whyy

bzip it (Download 7zip, right click, 7zip -> Add to archive -> .bz2 on Ultra)

Still no dice

The .bz2 file is smaller, so it will download faster, that’s the point

http://puu.sh/jFAH8.png

I mean it doesn’t work it downloads at the same speed

The difference in file size is what matters.
1 mb/s will take 16 seconds for the .bz2 file, 49 seconds for the .bsp …

I meant the fastDL is downloading at the regular sh*tty Gmod speeds, hmm time to figure that out now

Did you properly set the fastdl download url in the server’s configuration?
Is the web server publicly available for the downloading clients? (No CloudFlare stuff and whatever!)
Does the web server has enough engress bandwidth?

Yes yes and yes