Couldn't find 'weapons/weapon_ttt_binoculars/"WEAPON".lua' (<nowhere>)

I am trying to get rid of any lua errors and there is a ton of “weapons/weapon_ttt_binoculars/“WEAPON”.lua’ (<nowhere>)” should i be concerned or is this normal



[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_beacon/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:23: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_binoculars/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_binoculars/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:23: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_c4/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_c4/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_confgrenade/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_confgrenade/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_cse/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_cse/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_decoy/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_decoy/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_defuser/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_defuser/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_flaregun/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_flaregun/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_glock/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_glock/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_health_station/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_health_station/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_knife/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_knife/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_m16/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_m16/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_phammer/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_phammer/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_push/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_push/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_radio/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_radio/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_sipistol/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_sipistol/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_smokegrenade/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_smokegrenade/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_stungun/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_stungun/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_teleport/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_teleport/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_unarmed/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_unarmed/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_wtester/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_ttt_wtester/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_tttbase/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_tttbase/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_tttbasegrenade/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_tttbasegrenade/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_zm_carry/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_zm_carry/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_zm_improvised/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_zm_improvised/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_zm_mac10/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_zm_mac10/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_zm_molotov/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_zm_molotov/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_zm_pistol/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_zm_pistol/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_zm_revolver/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_zm_revolver/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_zm_rifle/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_zm_rifle/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_zm_shotgun/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_zm_shotgun/shared.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'weapons/weapon_zm_sledge/shared.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'weapons/weapon_zm_sledge/shared.lua' (<nowhere>)
Not running script addons/nyan cat gun - ttt/lua/entities/ent_nyan_bomb.lua - it's too short.L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'effects/base/init.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'effects/base/init.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'effects/crimescene_dummy/init.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'effects/crimescene_dummy/init.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'effects/crimescene_shot/init.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'effects/crimescene_shot/init.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'effects/dof_node/init.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'effects/dof_node/init.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'effects/pulse_sphere/init.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'effects/pulse_sphere/init.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'effects/teleport_beamdown/init.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'effects/teleport_beamdown/init.lua' (<nowhere>)
L 05/02/2014 - 22:30:24: Lua Error: [AddCSLuaFile] Couldn't find 'effects/teleport_beamup/init.lua' (<nowhere>)

[AddCSLuaFile] Couldn't find 'effects/teleport_beamup/init.lua' (<nowhere>)
HTTP failed - ISteamHTTP isn't available!

Update your TTT, you’re running a really old version.

Is there a way I can check what version I’m running ?

If you use the SVN or Git it won’t matter because it will automatically update

Still not a smart idea though if you plan on using custom code in the gamemode. You can see what version you’re on usually right after you join and a round starts, it also says it in the gamemode’s shared.lua. It should say GM.Version = “version”
The newest version is 2014-03-09

ok, im running “Trouble in Terrorist Town, version 2014-03-09”

I still get the errors :confused:

Just reinstall TTT, the weapon files were moved from weapons/<wepname>/shared.lua to weapons/<wepname>.lua