Couldn't Load Library 'gmhtml' (looking for interface IGMHTML001)

Hello, I just recently built a new computer, so I have been installing all my games on it. When I try to play Garry’s mod however, the game crashes on launch, and I get the error in the thread topic. I have tried just about everything I can think of, as well as everything I have found on the internet regarding this issue. I have obviously reinstalled the game, I have tried verifying the integrity of the cache, I have tried migrating my entire steam folder from my hard drive to my SSD (since I have steam library folders on both drives). None of this has worked. I actually had my friend send me his gmhtml.dll file for me to place in my bin folder, but to no avail.

If anyone has any idea what causes this issue, or how to fix it, I would greatly appreciate any help.

Thanks in advance!

Edit: I’ve now also tried disabling Steam cloud sync, disabling my antivirus, and using a third party tool to delete my Steam cloud files for Garry’s mod. Also, I have no subscribed files in the workshop.

Install DirectX 9?

According to dependency walker, gmhtml.dll depends on awesomium.dll, and THAT depends on XINPUT9_1_0.dll and D3DX9_43.dll, which are part of DirectX.

I have windows 10, and I tried just going to microsoft’s site and installing DX9, but it said I had to have an older version of Windows. Then I googled how to install DX9 on Windows 10 and tried the download link they provided in the first result forum thread (still from Microsoft) and the game still does not work. :frowning:

Download dependency walker, and drag Awesomium.dll onto the window. After a few seconds, it will (most likely) pop up a message about missing imports. Ignore that for now. Collapse all of the tree nodes on the left except for the root node (Awesomium.dll). Resize the panes so that all descendants of Awesomium.dll are visible. Post a picture of the result. Here’s mine as an example:

Here you go.

I thought for sure there would be a missing DLL problem, but everything looks normal. Lets try another approach.

I wrote a very simple test program. It will try to load gmhtml.dll and create the IGHTML001 interface. If it fails at any step, it will report an error. You can download it here. I’ve included gmhtml.dll, Awesomium.dll, and tier0.dll for convenience, as the tester will require them to be in the same folder.

“Test successful”

Hmm…

I changed the test program to search for gmhtml.dll and Awesomium.dll in a manner that is similar to how gmod does it. Download it here, and place it next to your hl2.exe. Make sure you do NOT place the DLLs you downloaded earlier next to it. Post all of the output if it doesn’t end with ‘Test successful’ again.

I would also like you to check the following locations on your computer, to see if another Awesomium.dll exists there:

<gmod folder>\garrysmod\bin\awesomium.dll
C:\Windows\System\awesomium.dll
C:\Windows\awesomium.dll
<gmod folder>\awesomium.dll

According to Process Monitor, those locations are checked before the Awesomium.dll that ships with gmod is found. For reference, it should only be found here:

<gmod folder>\bin\Awesomium.dll

I could not find awesomium.dll in any of those locations. The only place I found it was in GarrysMod\bin\awesomium.dll.

Not sure I put all of this in the right spot:

(Module Tester folder is where the old one is in)

Regardless, here is the result:

Wow… that error message really doesn’t make sense… gmhtml.dll should be looking for that symbol in Awesomium.dll, not in itself. I’m not really sure how that’s possible. However, I’m confident that this is the same error that is plaguing your gmod.

I’ve only got 1 more thing for you to try. Replace your Awesomium.dll and gmhtml.dll with the ones you downloaded from my dropbox earlier. If that doesn’t fix it, then I don’t know what will. If that does fix it, then I have to wonder how this problem managed to not get fixed from verifying the game cache…

If I put Awesomium.dll and gmhtml.dll both in my GarrysMod/garrysmod/bin folder, the game crashes but without an error message. If I put your Awesomium.dll in my GarrysMod/bin and your gmhtml.dll in my GarrysMod/garrysmod/bin, I get a crash still and the same old error.

I suppose my game is just broken on this computer for some reason or another. I really appreciate your help and consistency in responding to me regularly; you’ve been very patient.

The first test I had you run demonstrated that the dlls are capable of working on your computer, but for whatever reason, when they are in their proper locations, it screws up horribly.

I decided to manufacture an “Entry Point Not Found” error on my own computer so that I could investigate methods of gathering useful information from it. I ended up getting an equally confusing error message, which tells me that your error message isn’t as crazy as I thought it was. Microsoft seems to have really screwed up error reporting nowadays.

The most likely explanation is that the game is finding some other Awesomium.dll on your hard drive, just not in the locations I had you look in. To find out what modules it is ACTUALLY loading, I’m going to need a minidump. First, download Process Explorer. Process Explorer is basically Task Manager, but on steroids. Then, run my second test. When the “Entry Point Not Found” error occurs, do NOT close the messagebox. Just leave it as is. Open up Process Explorer, and find the running process for the test program. Right-Click on it and select Create Dump/Create Minidump. Save the file somewhere and PM it to me.

I’ve looked at the crash dump you sent me, and I’ve found your rogue awesomium.dll


C:\Windows\System32\awesomium.dll

Delete that file, and you should be good to go.

Here are all of the instances of awesomium.dll I have on my C:\ drive.
I don’t see one in System32, unless of course SysWow64 is the equivalent.

Yeah, SysWOW64 ones should also be removed.

I actually just deleted the one in SysWOW64 and my game worked after a quick (1 min) “update.”

THANK YOU SO MUCH, FRIEND! I haven’t been able to play in ages, but now I can thanks to you! You are my hero!

[editline]29th September 2016[/editline]

Thanks, both of you!

Time to update Support articles with new info I suppose.