Couldn't load module library!

I am getting the Couldn’t load module library!

And it is talking about, require(“tmysql4”)

I also use libmysql.dll

And I have the Lua\bin\gmsv_tmysql4_win32.dll

How do I install Microsoft Visual C++ for Vilayer? I don’t understand really how most modules work. :expressionless:

Please help. This is making my gamemode “Base Gamemode”

It’s gmsv_tmysql4_win32.dll


[ERROR] gamemodes/seriousrp/gamemode/init.lua:10: Couldn't load module library!
  1. require - [C]:-1
   2. unknown - gamemodes/seriousrp/gamemode/init.lua:10
    3. DeriveGamemode - [C]:-1
     4. unknown - gamemodes/metro/gamemode/init.lua:10



[ERROR] gamemodes/seriousrp/gamemode/init.lua:10: Couldn't load module library!
  1. require - [C]:-1
   2. unknown - gamemodes/seriousrp/gamemode/init.lua:10
    3. DeriveGamemode - [C]:-1
     4. unknown - gamemodes/metro/gamemode/init.lua:10

L 12/01/2012 - 16:12:58: Lua Error: Couldn't Load Init Script: 'seriousrp/gamemode/init.lua'

If you have libmysql.dll in the same folder as srcds.exe then you probably don’t have the correct C++ Redist installed. If you are certain you have the libmysql.dll in the correct place just make a ticket with your host.

I’m not using srcds, it works in srcds and singleplayer but not the host, so, what should I ask my host? And I do have libmysql.dll in the right place. orangebox/libmysql.dll

I’m getting the same error with the same module what do I need to update to fix it?

Fixed it. Get this: http://www.microsoft.com/en-au/download/details.aspx?id=30679

Make sure it’s the x86 version since you’re using 32bit modules.