Counter Strike: Source - Stuff does not load

Hi,
before you ask: YES, I have CS:S, YES, I bought GMod, and YES, I also bought CS:S.
Everything worked just fine until today. When I wanted to play some TTT, I was suddenly confronted with following issues:

Since this is a CS:S map, I suppose it’s an error with the CSS textures. They’re not being loaded into GMod.
Also, when I spawn CS:S stuff (SP and MP), I instead get Errors. The rest (TF2, Portal) works.
What could be wrong?

Try unmounting, and then remounting, CS:S to GMOD. (Inbetween mounts/unmounts you reboot GMOD of course.)
If that doesn’t work, attempt a reinstall of CS:S.

So un- and remounting didn’t work, but then I had the idea of starting CS:S. Don’t know if it worked yet, but Steam tries to verify the game cache by itself.

None of the maps from Counter Strike Source is loading up either.

Alright, let it validate 100%, restarted GMod, and voila: No pink-black textures again. Thanks for your help.

I wish I read this sooner, from the last update I reinstalled counter-strike source completely with a 20kb/p :frowning: