CounterStrike: Source default maps not loading.

Recently bought CSS, and decided to reinstall GMod.

Not long into playing, I notice that I can’t use most of my css maps, such as cs_office, de_estate (And heaps more).

I’ve reinstalled them, verified both caches numerous times.

Help?

Edit: Some work, some don’t. It’s like the maps are corrupted.

Have you run CS:S at least once before playing GMod? Also, check the mod settings in GMod to make sure it’s allowed to use the content.

Yeah, I played it before I started. I’ll get the actual console error next time I boot up.

Try the load map command in the console.

That would be typing this:


map <mapname>


 map cs_office

CModelLoader::Map_IsValid: ‘maps/cs_office.bsp’ is not a valid BSP file
map load failed: cs_office not found or invalid

Related, the maps that don’t work don’t have images on the maplist.

Not really, it just means no one has bothered to take a screenshot and resize it for the maplist.

Have you deleted the caches and then reinstalled?
For me, ‘Delete Local Content’ doesn’t always delete the gcf.

I’m just making sure.

No, hurr, don’t. Go to Extensions, and game content, make sure CS:S is ticked, once ticked, restart Gmod and try it.

It’s like half the maps, all the textures and models work. (I’ve tried that)

When a server tries to load one of the maps, (CS_Office, for starters) It goes “Could not CRC map maps/cs_office” or something along those lines.

Ususally I just delete the offending map, but that doesn’t exactly work with stock maps.

I’m pretty sure (all of the stock ones) most of the CSS maps all have screenshots.

Try to extract the missing maps from the Counter strike: source shared.gcf with GcfScape and put them in your gmod maps folder.

GcfScape: http://nemesis.thewavelength.net/index.php?c=169

I had the same problem, after I switched over to my Laptop. I looked and my CS:S wasn’t fully downloaded. Your problem probably isn’t this simple, but if it helps…
It worked after I finished the DL.

Worked for me in gmod9… Along time ago…