CQ File Doesn't Call .smd

I am having a problem with my custom .cq files calling upon an exported .smd file I have.

My .cq file is as


$modelname			   "player\charizards\charizards.mdl"
$cdmaterials	"materials\models\charizards\"

$texturegroup skinfamilies
{
	{"body_white.vmt"
	 "eye.vmt"}
	
	{"body_yellow.vmt"
	 "eye.vmt"}

	{"body_blue.vmt"
	 "eye.vmt"}
	
	{"body_red.vmt"
	 "eye.vmt"}

	 {"body_green.vmt"
	 "eye.vmt"}
	
	{"body_black.vmt"
	 "eye_blue.vmt"}
}

//$origin  0 0 0 90

$scale		1		// before any SMDs

$body body	"charizards.smd"
$surfaceprop	flesh

$upaxis Y

$sequence idle	smd "idle" fadein 0 fadeout 0 autoplay loop fps 30.00 


$collisionmodel	"charizards.smd"
{
$concave
$maxconvexpieces 500
}


I am using GUIStudio to compile. I have no idea what to write so my file brings on over the charizards.smd file to compile into an .mdl. Basically I’m using the charizard model from model resources and I have to make custom animations for it, and I have to use the SMD that comes with it but I’m having issues. Can anyone help me out?

Don’t you mean .qc? Also,

$sequence idle smd

You don’t have an SMD there.

Yeah my bad. Long day.

Do I have to put it as a file path or just the .smd name? I did it as so:

$sequence idle compiling\charizards.smd “idle” fadein 0 fadeout 0 autoplay loop fps 30.00

And it still does not work. I also tried

$sequence idle charizards.smd “idle” fadein 0 fadeout 0 autoplay loop fps 30.00

And still nothing. I have the compiling folder in my tf folder

How its called the idle anim? “idle” too?:

I’m sorry, I don’t understand what you are trying to say.


$sequence <name> <.SMD> <options>

That’s the proper syntax. Right now you have:



$sequence   idle  charizards.smd   "idle"    fadein 0 fadeout 0 autoplay loop fps 30.00 
$sequence  <name>   <.SMD>         <.SMD>                    <options>

Change it to:


$sequence idle charizards.smd

For an idle animation you don’t need any of those options.