Crafty Texture problems

Hello, i am trying to get crafty to load bsps from gmod but for some reason, only some of the textures show up.

Is there any way to fix this?

Ive tried mounting the steam-apps folder and it had fixed some but not all textures.

I think crafty broke with steam pipe? Somebody could correct me…

You can try using WallWorm if you’re trying to take the map into another editor.

tried using wall worm and was having problems with it.

Ill post a log of what happens when i try to load a map like gm_construct inside crafty.

Here is what the map looks like in crafty: https://i.imgur.com/bdgUgzQ.png

Log: https://pastebin.com/UkJGjvXt

In \crafty102\Specifications\GameInfoCustom.csf did you make an entry for garrsmod i.e like


"Modification"
	{
		"Game"		"Source"
		"Name"		"Garry's Mod"
		"Category"	"Source 3rd Party"
		"Root"		"SourceMods"
		"MountPoints"
		{
			"MountPoint"	"source materials.gcf"
			"MountPoint"	"source models.gcf"
		}
		"SearchPaths"
		{
			"SearchPath"	"garrysmod"
			"SearchPath"	"hl2"
		}
	}

also crafty can’t read .vpks so you have to extract the materials from them

Yup, i have made that entry.
How would i extract the materials from vpk files so they can be read by crafty?

i don’t think i have been doing that correctly as crafty does not seem to notice them.

Ive managed to export a map with all its textures but i have issues with importing it into 3ds max.

For some reason, the whole model is using only one of the textures. I don’t know why that is happening.

Why is this happening? : https://i.imgur.com/9wRKlhD.png

The textures are there but the program is not spotting them. :frowning:

Doesn’t look like your textures are in the correct path?

Also, I believe gm_bigcity has some form of protection on it. Have you tried with another map that isn’t protected?

i managed to rip gm_bigcity fine. trying to rip gm_fork as a test

i mounted this folder into crafty but nothing has changed: https://i.imgur.com/zM1AIzj.png

[editline]2nd October 2017[/editline]

the main problem is that the program does not seem to be spotting the textures ive mounted onto it.
no idea why its not using them :frowning:

[editline]2nd October 2017[/editline]

If you have been wondering what i was wanting to use the maps for, well: https://i.imgur.com/BYiJjeS.jpg

Well it seems that crafty cant use custom textures so thats that i guess. :frowning:

If anyone knows how to convert bsps to obj without any missing textures, please tell me.

I think you need CS Source and HL2 Textures, i’m doing that rn with bigcity to see if it works so i can port it to Assetto Corsa :slight_smile:

Heh, fancy seeing you here, ive managed to fix crafty anyways, turns out it was me being stupid and mounting the wrong location.

Its me, Matthew from steam.

Well that really F A N C Y

But how you fixed it? it still got some white textures for me on crafty and i alraedy mounted cs source gmod, extracted all the gmod materials from those .vpk and also hl2ep2