Crash after "POST init systems"

I have problem with Garry’s Mod. It is annoying and i really going out of ideas what made it. Maybe let’s start from beginning.
I launching GMod like always. Loading with nice blue screen and facepuchstudios logo. When it goes into “P.O.S.T.” or “Post…” [i don’t sure it’s testing or something else function]"…Init systems" it just show little steam color window in left top corner [nothing is writing in it] and it show me very nice and good HL2.exe has stopped working… First i think something going wrong with addons LUA. Nope Gmod say… Maybe lua folder or bin is broken? Again nope. Reinstall? still crash. Then i just remember yesterday steam downloaded something big for tf2. Maybe engine is **** **? hmmm i see other people don’t have that, so it is in my pc problem. Everything in Friday was fine. i done a lot of hard work at doing own spawnlists…
I don’t sure my pc spec can do it…
I have *.MDMP file for somebody can look what is wrong. : http://hostuje.net/file.php?id=5db65f3078dbf865196174c22bda5c40
http://hostuje.net/file.php?id=1f897be923037781a79aaf8a1a815ed6

Sorry for my very bad English… 7 years of study is still not enough

EDIT: i add some photo to show how it looks
http://imageshack.us/photo/my-images/32/hl22012110416011633.png/
http://imageshack.us/photo/my-images/542/hl22012110416011764.png/
http://imageshack.us/photo/my-images/836/hl22012110416011831.png/
http://imageshack.us/photo/my-images/402/hl22012110416012141.png/
On last screen in center is error HL2.exe has stopped working… fraps don’t catch that

Sorry for bumpy bump but i really need little help… it isn’t so hard to notice this…

Problem Solved!!
Issue: .GCF file was corrupted
Fix: do clean reinstall number [you try number here] then install game from GCF downloaded from another pc.
I think my gcf was **** ** by that mighty update for tf2… good i have somebody else can give me original GCF file… ufff
All my work is back on rail! God save the Gmod!

i have the same problem that you had by any chance can you help me?