[CRASH] GMod Crashing on Undo/Removing Specific Entity Family

Whenever I undo any entities that use the same base entity, or the entities that comes with the upload, my games instantly CTDs. I have verified files, uninstalled/reinstalled, removed all legacy/workshop addons/gamemodes, and run with only the addon in question and it crashes when they are removed.

All other entities work fine except one, and the author of the addon can’t replicate it. The other entity that CTDs my game are bombs from a jet exploding from the same author, but the missiles on the jet do not cause crashes when they explode.

Dump Files:
http://www.mediafire.com/?frk5r5d923e8rau
http://www.mediafire.com/?pk388s9srd2dkl3
http://www.mediafire.com/?38132eyhiq5vuco

I am unable to continue making addons until I can solve this problem; thanks in advance.

Anyone? I’ve tried literally everything and it still is broken.

Edit:

I found a crash dump analyzer:




Crash Dump Analysis provided by OSR Open Systems Resources, Inc. (http://www.osr.com) 
Online Crash Dump Analysis Service 
See http://www.osronline.com for more information 
Windows 7 Version 7601 (Service Pack 1) MP (8 procs) Free x86 compatible Product: WinNt, 
suite: SingleUserTS Personal kernel32.dll 
version: 6.1.7601.18015 (win7sp1_gdr.121129-1432) 
Machine Name: Debug session time: Fri Oct 18 08:21:53.000 2013 (UTC - 4:00) 
System Uptime: not available 
Process Uptime: 0 days 0:04:30.000   
Kernel time: 0 days 0:00:13.000   
User time: 0 days 0:03:12.000 
TRIAGER: Could not open triage file : e:\dump_analysis\program	riage\oca.ini, error 2 
TRIAGER: Could not open triage file : e:\dump_analysis\program\winxp	riage.ini, error 2 
TRIAGER: Could not open triage file : e:\dump_analysis\program	riage\user.ini, error 2 
*******************************************************************************
*                                                                             *
*                        Exception Analysis                                   * 
*                                                                             * 
*******************************************************************************  
*** WARNING: Unable to verify timestamp for lua_shared.dll 
*** ERROR: Module load completed but symbols could not be loaded for lua_shared.dll 
TRIAGER: Could not open triage file : e:\dump_analysis\program	riage\guids.ini, error 2
*** WARNING: Unable to verify timestamp for tier0.dll 
*** ERROR: Module load completed but symbols could not be loaded for tier0.dll
*** WARNING: Unable to verify timestamp for filesystem_stdio.dll 
*** ERROR: Module load completed but symbols could not be loaded for filesystem_stdio.dll 
Unable to load image E:\Steam\steamapps\common\GarrysMod\bin\vstdlib.dll, Win32 error 0n2 
*** WARNING: Unable to verify timestamp for vstdlib.dll 
*** ERROR: Module load completed but symbols could not be loaded for vstdlib.dll 
*** WARNING: Unable to verify timestamp for nvd3dum.dll 
*** ERROR: Module load completed but symbols could not be loaded for nvd3dum.dll 
*** WARNING: Unable to verify timestamp for engine.dll 
*** ERROR: Module load completed but symbols could not be loaded for engine.dll 
*** WARNING: Unable to verify timestamp for bass.dll 
*** ERROR: Module load completed but symbols could not be loaded for bass.dll 
*** WARNING: Unable to verify timestamp for awesomium.dll
*** ERROR: Module load completed but symbols could not be loaded for awesomium.dll 
*** WARNING: Unable to verify timestamp for client.dll 
*** ERROR: Module load completed but symbols could not be loaded for client.dll 
TRIAGER: Could not open triage file : e:\dump_analysis\program	riage\modclass.ini, error 2  
FAULTING_IP:  +23d8d4 00000001 ??              ???  
EXCEPTION_RECORD:  ffffffff -- (.exr 0xffffffffffffffff)
 ExceptionAddress: 00000001    
ExceptionCode: c0000005 (Access violation)   
ExceptionFlags: 00000000 
NumberParameters: 2    
Parameter[0]: 00000008    
Parameter[1]: 00000001 
Attempt to execute non-executable address 00000001 
DEFAULT_BUCKET_ID:  SOFTWARE_NX_FAULT  
PROCESS_NAME:  hl2.exe  
ERROR_CODE: (NTSTATUS) 0xc0000005 - The instruction at "0x%08lx" referenced memory at "0x%08lx". The memory could not be "%s".  
EXCEPTION_CODE: (NTSTATUS) 0xc0000005 - The instruction at "0x%08lx" referenced memory at "0x%08lx". The memory could not be "%s".  
EXCEPTION_PARAMETER1:  00000008  
EXCEPTION_PARAMETER2:  00000001  
WRITE_ADDRESS:  00000001   
FOLLOWUP_IP:  server+23d8d4 1f4ed8d4 ??              ???  
FAILED_INSTRUCTION_ADDRESS:  +23d8d4 00000001 ??              ???  
FAULTING_THREAD:  00003c24  
PRIMARY_PROBLEM_CLASS:  SOFTWARE_NX_FAULT  
BUGCHECK_STR:  APPLICATION_FAULT_SOFTWARE_NX_FAULT  
LAST_CONTROL_TRANSFER:  from 1f4ed8d4 to 00000001  
STACK_TEXT:   WARNING: Frame IP not in any known module. Following frames may be wrong. 0025df6c 1f4ed8d4 05a4c8d0 05a4c3d0 aa4ed8c8 0x1 0025df80 1f4ab156 05a4c8d0 05a4c3d0 1facc4b4 server+0x23d8d4 0025e0ec 1f616310 135fcd10 00000000 00000000 server+0x1fb156 0025e13c 1f6167b3 0963aa60 135c02e8 135c01c0 server+0x366310 0025e14c 544550ab 135c01c0 2cc02620 0025e164 server+0x3667b3 0025e150 135c01c0 2cc02620 0025e164 0025e174 lua_shared+0x150ab 0025e154 2cc02620 0025e164 0025e174 135f9840 0x135c01c0 0025e158 0025e164 0025e174 135f9840 00000002 0x2cc02620 0025e15c 0025e174 135f9840 00000002 25ee3dd8 0x25e164 0025e164 00000000 25ee3dd8 00000000 135c0210 0x25e174   
STACK_COMMAND:  ~0s; .ecxr ; kb  
SYMBOL_STACK_INDEX:  1  SYMBOL_NAME:  server+23d8d4  
FOLLOWUP_NAME:  MachineOwner 
MODULE_NAME: server 
IMAGE_NAME:  server.dll  
DEBUG_FLR_IMAGE_TIMESTAMP:  52341d3d  
FAILURE_BUCKET_ID:  SOFTWARE_NX_FAULT_c0000005_server.dll!Unknown  
BUCKET_ID:  APPLICATION_FAULT_SOFTWARE_NX_FAULT_BAD_IP_server+23d8d4  
WATSON_STAGEONE_URL:  http://watson.microsoft.com/StageOne/hl2_exe/0_0_0_0/52341c19/unknown/0_0_0_0/bbbbbbb4/c0000005/00000001.htm?Retriage=1  Followup: MachineOwner

Edit:

I removed myself from the Dev Branch and it works again; something in the last Dev branch update broke it.