Crashes at ULX MOTD on a random server

I go to join a RP server (SonsOfGarry) and it just crashes from there.
That annoys me so much. Why cannot Garrys Mod give me some sort of diagnoses?
I would not mind… But I have downloaded Half Life 2 Counter Strike Source and Garrys Mod right before my holiday (In case there was no WiFi which there is) I went on Sons Of Garry last night and it worked perfectly for me (Just Like it did 3 times before) but now today when I went to join it crashed at the ULX MOTD.

Q: “Why dont you just redownload Garrys Mod?”
A:
I have asked at the place im staying and they said multiplayer gaming is allowed but not downloading anything over 100mb.
I sometimes get the same problems on other servers too.

So… any one got a fix?
I have cleared my addon folder…
I have validated Garrys Mod
I have installed absolutely nothing before the problem.

Specs:
2Gb DDR3 Ram
Nvidia 9400M 512 Mb
Windows XP SP2

Its an Apple Macbook Aluminium.
Please don’t say anything like: “Why would you even want to play any games on a Mac any way? it would suck” Because I have played Garrys Mod maxed just fine.

Your video RAM is a bit low, have you tried turning down settings/resolution or using -dxlevel 81 in the start up options?