Crashes on Single Player Map Load

I’m going to try to be as specific as possible here, so just bear with me.

Ever since the M9K (which I have currently deleted) update on August 21st, IIRC, Gmod has been crashing when I try to load Sandbox in Single Player. The progress bar gets to about the end, then GMod just crashes. No hl2.exe has stopped working, it just dies. I’ve been constantly deleting certain addons, reinstalling all my addons, reinstalling GMod itself, verifying the Game Cache Files,but I can’t seem to fix the problem. I tried Googling a solution to the problem, but I couldn’t seem to find anyone with the exact problem. I thought I might be hitting the LUA limit (and with 511 addons, I wouldn’t doubt it), but GMod doesn’t alert me about it due to the crashes, and I’m fairly certain that the LUA limit doesn’t crash the game. I’m pretty sure one of my addons is doing this, but I have so many that I just wouldn’t have the patience to test each one individually. Does anyone know some way to get it working again?

Have you physically unsubscribed from the addons or have you just deleted them?

Unsubscribed then deleted.

Have you tried disabling all addons?

So, the problem is definitely one of my addons. I disabled everything and the game worked.

Would conflicting addons crash the game?

It’s possible

This is the most recent crash dump. Can anyone check to see what fucked up?
http://www.mediafire.com/download/pz0daaaw8c64q4h/hl2_130912_crash_2013_9_26T16_1_28C0.mdmp

Upload it to http://dumps.metastruct.uk.to and post the link

Sure thing.
http://dumps.metastruct.uk.to/dumper.py?dump=hl2_130912_crash_2013_9_26T16_1_28C0.mdmp

The crash log has no crashing/lua errors. Just keep enabling groups of addons until you find out which one(s) are causing the issue.

I deleted two packs of SCars (the GTA Vice City cars and bikes) and now everything works again.