Crashes when shooting an NPC.

hey there, I just got Gmod, I have CSS and thats it. It wouldnt run so i looked that up and someone told me to type -dxlevel 81
it works, but whenever I shoot an NPC, or it shoots me, or even when an NPC shoots an NPC it crashes…
Why?

-dxlevel 90
Try that instead

-dxlevel 90 makes it crash at startup… -dxlevel 80 makes it run fine, but no HUD… and -dxlevel 70 is the same as 80

Intel card, right? Try +mat_forcehardwaresync 0 +mat_bumpmap 0 +mat_specular 0 -dxlevel 90

i have the same problem and +mat_forcehardwaresync 0 screws EVERYTHING up. No crosshairs no health bar. Big black splotches in the screen when trying to join a game or starting singleplayer

that didnt help at all…

You could always ask the npc to suicide, he may not answer though :confused:

What are your specs?

Processor Information:
Vendor: GenuineIntel
Speed: 1595 Mhz (1.6 Ghz)
2 logical processors
2 physical processors
HyperThreading: Unsupported
FCMOV: Supported
SSE2: Supported

Network Information:
Network Speed:

Windows Version:
Windows Vista (32 bit)
NTFS: Supported

Video Card:
Driver: BB Capture Driver
DirectX Driver Name: igdumd32.dll
Driver Version: 1.00
DirectX Driver Version: 7.14.10.1295
Driver Date: 10 June 2009
Desktop Color Depth: 32 bits per pixel
Monitor Refresh Rate: 59 Hz
DirectX Card: Mobile Intel® 965 Express Chipset Family
VendorID: 0x8086
DeviceID: 0x2a02
Number of Monitors: 1
Number of Logical Video Cards: 1
No SLI or Crossfire Detected
Primary Display Resolution: 1280 x 800
Desktop Resolution: 1280 x 800
Primary Display Size: 17.80" x 11.10" (20.94" diag)
45.2cm x 28.2cm (53.2cm diag)
Primary Bus Type Not Detected
Primary VRAM: 213 MB
Supported MSAA Modes Not Detected

Sound card:
Audio device: Speaker/HP (Realtek High Defini

Memory:
RAM: 2037 Mb (2gb)

I was asking sakarias about it cause i had the same problem.he told me that it might be my addons.for any of you who have problems try resetting your gmod it may have too many addons
i told him that wasnt my problem
he then told me that it was probably my laptop.
i understand that line,because im using a business laptop,not a gaming laptop.
so if it isnt your gomd you might need a new procceser or laptop

well isnt there anything I could do?
I updated my drivers and now it shows the hud on dxlevel70 but it crashes when I shoot now… :frowning:

There is no such thing. Get a (stationary) PC.

Try the following:

+mat_forcehardwaresync 0 -dxlevel 70 +mat_bumpmap 0 +mat_specular 0 +map_background none -autoconfig

+mat_forcehardwaresync 0 -dxlevel 81 +mat_bumpmap 0 +mat_specular 0 +map_background none -autoconfig

+mat_forcehardwaresync 0 -dxlevel 90 +mat_bumpmap 0 +mat_specular 0 +map_background none -autoconfig