Crashing before starting... (HL2.exe has stopped working)

Ok so. I’ll get strait to the point. When I start Gmod it starts to load then just crashes. I have not installed any new addons or joined any unknown servers. I was on gmod the day before this happened yet now it won’t start. It will just load up and then say HL2.exe has stopped working.

System Info:

OS: 32 bit Windows 7 Ultimate
Video Card: ATI Radeon 3850 (Latest Drivers for Win 7)
CPU: Intel Core 2 Quad Q6600 @ 2.40GHz
RAM: 4GB

If there is any thing I should delete like caches folder lua files and such please tell me and also reinstalling Gmod is my last resort so please don’t make a post to do so.

Bump?

Oh nevermind I already re-installed -_-

I re-installed it and it still crashes.

What you need to do is goto the steam launch options for gmod, then type:
-dxlevel 80
And then save, and launch game.
That will fix it.

Never mind, I think I figured out my problem.

So does Gmod really doesn’t work when your grapic card is set to Directx10?

me too and it’s odd because I take back my “Nevrmind now” cuz it’s doing again after everything I did. Now I’m just trying 1 addon at a time to see what the problem is and it may not even me an addon it could be an lua file or something idk but it did work without any addons or lua files before I restored them to where they where. Also I have found out do far it’s not Stargate nor PHX nor Wire nor Wire Extras so idk what to do unless someone could post a list of lua files that crash your game or something.

[editline]04:05PM[/editline]

I’ll try.

[editline]04:06PM[/editline]

Nope not that :frowning:

I set it to -dxlevel 80 and still crashed. I’ll do a clean install add the addons 1 by 1 and then that will tell me the faulty one.

My friend gets this, it seems almost everyone gets it at one stage or another, he hasn’t even start gmod yet, so he can’t delete the sub-garrysmod folder, because he hasn’t got one.
Help? :downs:

No, I’m not having that problem. The game starts but before it reaches the main menu it crashes. That’s all.

OK I fixed it. It seemed to have been one of my lua files but it’s all good now and it only took 3 days :smiley:

Got mine working with the dx thing

Hold on il get the full launch options from my steam, that should help you.

EDIT:
-dxlevel 80 -console -novid -windowed -32bit

K, set that in the launch options and then restart steam (optional) and bam, should work!

EDIT:
BTW, the Novid, and Windowed options are optional, you dont have to use them