Crashing when joining a server or starting a single-player game.

Recently, I’ve been crashing whenever I join a server or start a game. I have no idea how I can find out what’s causing this. Is anybody else experiencing these crashes?

[editline]3rd November 2012[/editline]

I found this dump file from earlier today, but I’m not sure if this means much.



Console History (reversed)

245(127.746559):  PCall: not a function at -4!244(127.716709):  Redownloading all lightmaps
243(127.715341):  ERROR: GAMEMODE:'AdjustMouseSensitivity' Failed: gamemodes/base/gamemode/cl_init.lua:413: attempt to index local 'wep' (a number value)
242(127.715217):  ERROR: GAMEMODE:'CalcView' Failed: lua/includes/util.lua:184: attempt to index local 'object' (a number value)
241(127.667825):  TTT Client post-init...
240(126.265172):  
238(126.222665):  ULX version <SVN> unknown revision loaded.
237(126.222632):  Client "uS | Zach" spawned in server (192.168.0.3:27006)<STEAM_0:1:33059587>.
236(126.222524):  
[ERROR] addons/ulib/lua/ulib/cl_init.lua:53: attempt to call method 'IsValid' (a nil value)
  1. fn - addons/ulib/lua/ulib/cl_init.lua:53
   2. func - addons/ulib/lua/ulib/client/cl_util.lua:22
    3. unknown - lua/includes/modules/net.lua:31

235(126.187964):  ERROR: GAMEMODE:'Tick' Failed: lua/includes/util.lua:184: attempt to index local 'object' (a number value)
234(126.156262):  ERROR: GAMEMODE:'Tick' Failed: lua/includes/util.lua:184: attempt to index local 'object' (a number value)
233(126.123381):  ERROR: GAMEMODE:'Tick' Failed: lua/includes/util.lua:184: attempt to index local 'object' (a number value)
232(126.103814):  ERROR: GAMEMODE:'Tick' Failed: lua/includes/util.lua:184: attempt to index local 'object' (a number value)
231(126.090833):  ERROR: GAMEMODE:'Tick' Failed: lua/includes/util.lua:184: attempt to index local 'object' (a number value)
230(126.065950):  ERROR: GAMEMODE:'Tick' Failed: lua/includes/util.lua:184: attempt to index local 'object' (a number value)
229(126.052636):  ERROR: GAMEMODE:'Tick' Failed: lua/includes/util.lua:184: attempt to index local 'object' (a number value)
228(126.027831):  ERROR: GAMEMODE:'Tick' Failed: lua/includes/util.lua:184: attempt to index local 'object' (a number value)
227(126.016637):  ERROR: GAMEMODE:'Tick' Failed: lua/includes/util.lua:184: attempt to index local 'object' (a number value)
226(125.992377):  ERROR: GAMEMODE:'Tick' Failed: lua/includes/util.lua:184: attempt to index local 'object' (a number value)
225(125.981939):  ERROR: GAMEMODE:'Tick' Failed: lua/includes/util.lua:184: attempt to index local 'object' (a number value)
224(125.980768):  ERROR: GAMEMODE:'Tick' Failed: lua/includes/util.lua:184: attempt to index local 'object' (a number value)
223(125.891011):  ERROR: GAMEMODE:'Tick' Failed: lua/includes/util.lua:184: attempt to index local 'object' (a number value)
222(125.881519):  ERROR: GAMEMODE:'Tick' Failed: lua/includes/util.lua:184: attempt to index local 'object' (a number value)
221(125.879589):  ERROR: GAMEMODE:'Tick' Failed: lua/includes/util.lua:184: attempt to index local 'object' (a number value)
220(125.850893):  ERROR: GAMEMODE:'Tick' Failed: lua/includes/util.lua:184: attempt to index local 'object' (a number value)


[editline]3rd November 2012[/editline]

Fixed! All I did was delete everything in /garrysmod/lua/

Actually, multiplayer still crashes

Edit: Everything’s fine… if anyone has problems, try deleting everything in your lua folder.

where is your lua folder?

/garrysmod/lua…
or in the cache folder