Create server button broken?

Hi,

I run a hamachi server for my so I can play with my friends more easily without having to setup a dedicated server. Recently, whenever I try and load up through the create multiplayer button, the loading screen goes to initializing resources, then. Goes back to the main menu.

Help?

lol crack ver probably…

No, I bought the game legit off steam

i have hamachi also but i am not using it and i am trying to create a game just using my wan ip address and i get the smae thing as you it goes back to the main menu i don’t know what makes it do that though

Can anybody else contribute? I have spent many frustrating hours trying to look for a solution.

Try using the Create Multiplayer button alone without Hamachi running. You don’t need Hamachi to run a listen server.

Alright, I’ll tell you the end result later.

[editline]03:42AM[/editline]

Ok, I just tried it, it works without hamachi, but if I don’t have hamachi, my friend can’t join…

Any ideas?

He can still join, here’s how:

  1. Go to http://www.whatismyip.com/
  2. Start a server via the button
  3. In console type ‘sv_lan 0’ (no quotes)
  4. Again type ‘heartbeat’ in console (no quotes)
  5. Tell him to put this in console: ‘connect InsertIpHere’ (no quotes)

If that still doesn’t work add me on Steam.

lol, whatsmyip.com results in one of those domain advertisement sites

Sorry about the link, it’s fixed now.

Anyway, you need to forward your ports, here: http://www.portforward.com/

Ports that need to be open: 4380, 27000 - 27050 both UDP & TCP

I had port 27015 or something open, that’s what a lot fo people say you need open…
Does my friend need to open his ports too?

FooManChu I have the same problem but I want to play lan with some friends and I can’t cause it just goes back ot the main menu and I don’t use Hamachi

You need more than 27015 open. Open all the ones above.

And your friend doesn’t need his ports open.

cool stuff thanks

[editline]10:43PM[/editline]

According to Port Forward, my DI-614+ router cannot open enough ports for steam client. and also, I gotta do 27000 - 27050 one by one? DAMN LOL