Creating a model/Converting a model

I have a model already made, but what do i use to export it into a readable format for garry’s mod. Is it just a plugin for 3ds Max? Also, (and forgive me if this is a nooby question) is visio needed to make the .vtx,etc files? Thanks.

if you have smd files already, - you need Collision model, and a QC file.

If your model is ragdoll then it’s harder.
If it’s prop the you just need:

QC File
Model.smd
Model_Collision.smd
And a bit of brain :stuck_out_tongue:

ok well that sort of helps, but not really. I mean when i look in the model folder for garrys mod i see a whole bunch of .mdl’s, .vtx’s, and some other file extensions but no .smd’s. I’m completely new to making mods for Garry’s mod, so if you could point me to a tutorial, it would help a lot. What program do you use to open up the .mdl files, that way i can make a first person view of the weapon. If i have to do something to access the .smd’s first, then could someone please tell me what it is, 'cause im completely lost.

http://www.facepunch.com/showthread.php?t=542906&highlight=mariokart - Ragdoll Tutorial
http://www.facepunch.com/showthread.php?t=489566 - 3D Max Ragdoll Tutorial
http://www.jaanus.cc/flash/tutorial.html - Compiling Tutorial
http://developer.valvesoftware.com/wiki/Studiomdl - Compiler
http://developer.valvesoftware.com/wiki/Studiocompiler - Compiler
http://www.chaosincarnate.net/cannonfodder/cftools.php?program=studiocompiler - Compiler
http://nemesis.thewavelength.net/index.php?c=178 - Texture files to VTF converter (very good one aswell)
http://blog.gneu.org/software-releases/obj-2-smd-converter/ - If its a prop you could also export it as a .obj file and use this

Any help? Also you will need to do a google search for a 3D Max SMD Exporter plugin, you’ll find loads.

Also you don’t need visio, as there not even a visio file, vista just shows them as such. The compiler will make all the files needed from the SMDs and QC file you provide it with.

ok thanks a lot this helps a ton. is there anything special i need to do for weapons?

[editline]05:20AM[/editline]

when ever i run GUIStudioMDL, and then try compiling with the .qc i made (following jaanus’s tutorial) it keeps giving me this error: “ERROR: c:\users\echelon\desktop\viper\viper.qc(1): - bad command $”. Does anyone know what that means i did wrong, or what i have to fix?

That’s exactly the same message i get… I managed to get past it but i can’t remember how i did it, and after setting up my next model identicaly to that one, it still wont work… Last time i think i put the folder with the SMD and the QC on my desktop… but i can’t remember if i edited any files…

You know… I wonder if that has something to do with you copying and pasting the .qc. It’s a long shot, but you might want to try and type your own $ where you have them in your .qc and see if that gets rid of the error.

I worked that out on my own! :smiley:
But yeah thanks for ruining my glory, I was going to come raging in with massive capital letters.

Yeah so guys, I fixed this problem by re-writing my .qc, It would probably help to use notepad++

notepad++ ftw. wouldnt use anything else. alright ill try that.

[editline]08:30AM[/editline]

well, no that didn’t work. here, I’ll paste the whole log it made.
Loaded QC file - “C:\Users\echelon\Desktop\Viper\viper.qc”

Created command line: “C:\Program Files\Steam\steamapps\1upechelon3\sourcesdk\bin\ep1\bin\studiomdl.exe” -game “C:\Program Files\Steam\steamapps\1upechelon3\garrysmod\garrysmod” -notxbox C:\Users\echelon\Desktop\Viper\viper.qc

qdir: “c:\users\echelon\desktop\viper”
gamedir: “C:\Program Files\Steam\steamapps\1upechelon3\garrysmod\garrysmod”
g_path: “viper”
Working on “viper.qc”
ERROR: c:\users\echelon\desktop\viper\viper.qc(1): - bad command $

post your QC file.

you have some bad command.

$modelname “models\weapons\viper.mdl”
$cdmaterials “echelon3”

$scale 1
$surfaceprop “metal”

$sequence idle “viper.smd” fps 1

$collisionmodel “viper.smd” {
$mass 100.0
$inertia 1.00
$damping 0.00
$rotdamping 0.00
}

[editline]01:32PM[/editline]

i think i mightve figured out the problem. lemme do something.

Use this one…

"
**$modelname “<Subdir>\model.mdl” **// <<< Name of model (Where it’s going to)
$body mybody “Model.smd” // <<< Body of model (Leave “Mybody” the same)
**$staticprop // **<<< Static prop (For hammer, and property of prop it self)
**$surfaceprop metal **// <<< Prop material
**$cdmaterials “<Subdir>**” // <<< Meterial folder they are going to
$scale 1.0 // <<< Size

$sequence idle “Model.smd” loop fps 15 // <<< Model compile source and animation settings
^ (Even if there is no animation, this is a neccesity)
$collisionmodel “Model.smd” { $concave } // <<< Collision model
"

-This is the one i use and it works in GUIstudioMDL.exe :slight_smile:

Hope this helps