Creating entity with lua

hello everyone, I’m having trouble creating entity. When I tried to create it, it just didn’t show up in the entity tab, nor did the others tab itself. I don’t know what’s wrong, i tried whatch some videos about that but it doesn’t work. Maybe the syntax is wrong or i forget something?
server init:
AddCSLuaFile(“entities/init.lua”)
AddCSLuaFile(“entities/shared.lua”)

include (“entities/shared.lua”)

function ENT:Initialize()

self:SetModel("B:\Steam\steamapps\common\GarrysMod\garrysmod\materials\spawnicons\models\props_vehicles/van001a_physics.mdl.mdl")
selft:SetColor(Color(100,255,60))

self:PhysicsInit(SOLID_VPHYSICS)
self:SetMoveType(MOVETYPE_VPHYSICS)
self:SetSolid(SOLID_VPHYSICS)


local phys = self:GetPhysicsObject()

if (phys: IsValid()) then

phys:Wake()
end

end

client init:
include(“entities/shared.lua”)

function ENT:Draw()

self:DrawModel()

end

shared:
ENT.Type = “anim”
ENT.Base = “base_gmodentity”

ENT.PrintName = “Entity”
ENT.Instructions = “IDK”
ENT.Spawnable = true

Ent.Author =“Bearundiy”

Ent.Porpuse = “IDK”

Can you display the entire code in a readable way? I have trouble understanding it in its current form.

init_client
[this is client initialization]


[this is server initialization]

shared

[this shared]

SetModel accepts a path relative to the Garry’s Mod installation folder and not absolute to your computer’s hard drive. Here is an example: garrysmod/sent_ball.lua at 4aefc7d7f468998cd3239c0baa560a389f27d884 · Facepunch/garrysmod · GitHub

This is probably what causes the entity creation issue.

i changed, but nothing happens, does not appear in the tab
5643

image
image
Just look at the files you include too, the file names are incorrect.

ooooh, by bad.

that was part of the problem, it still doesn’t show

Do you have any errors in the development console?

nope

Then your code is simply not processed, where (the path) did you place your entity?

GarrysMod/garrysmod/lua/entities

What is the name of the folder? Which file does it contain?

folder is “printer”. It’s contains 3 files int_client, int_server and shared

Can you resend your three files after the last changes? I suspect that the include paths you specified are still incorrect.

client_init

The other two files are missing, please make some effort.

server init

sure, just because I’m new user, I have limited answers