CSS incorectly installed

Hi! I have tried many versions of DarkRP to get it to work. But it dosnt…
The weapons are floating in the air and you are unable to pick them up without a licence.

So I switched to this version who seemed good, but now it says
“Counter:Strike Source is incorrectly installed! You need it for DarkRP to work!”

So I used the hldsuptadetool and installed css in c:\HLserver, where my gmod is installed, orangebox and all that. But its still the same message, help me?

EDIT: This is a Gmod SERVER

Do you play gmod from that folder?

:downs:

You should put the cstrike folder with the css content in the orangebox like this
C:\srcds\orangebox\cstrike