CSS Textures are black & pink for everyone except me.

Hi! I just made a custom map for my TTT server, but all textures except for HL2 textures are black & pink for everyone.
I have no idea what the problem is because the map looks perfect for me :confused:

UPDATE: Seems like they can magically see the textures now :S Well, it works now, so :confused: Remove this post I guess.

Ill take a look at it.

Would you mind just uploading the VMF? Its easier to help if you do.

do they have CSS mounted?

http://www.filedropper.com/tttkossafarmb1_1 <- The VMF

[editline]30th July 2015[/editline]

Yes.

[editline]30th July 2015[/editline]

Those are .ain’s I need .vmf to see what the problem is.

Sorry, my bad, I selected the wrong file, I should’ve double checked.
http://www.filedropper.com/tttkossafarmb1_2 <- Here it is

Hmm. What are they seeing as errors? Walls, objects etc.

[editline]30th July 2015[/editline]

Never mind. Its an error to me aswell. Make sure your not using custom textures (Like from addons and what not.). If you still got a problem let me know.

I’m not using any custom models, only a few custom textures. I’m using the CSS hammer tool, so it’s not an addon or anything messing it up, so it’s the default CSS textures messing up :confused:

When I went in it seems to be the grass texture or what ever is on the ground. It is also the T-Room teleport texture and the skybox house windows. Fix that and it should work.

That’s very strange… Everyone on the server can see the grass, they can also see everything in the skybox, including the house windows. Hoewer the T-Room teleport textures are custom :S

These barn is 100% pink, and so is the house.
This is so confusing :S I even have a fresh install of css, so no custom content could be messing it up.

EDIT: I guess you mean the wheatfield when you say grass, but that’s also a custom texture and won’t show in the vtf, but the big problem is that normal CSS textures are F’d :confused:
ONLY HL2 textures show, regardless of if they have it mounted :confused:

EDIT2: It magically works now :S I did no changes, but thanks for the effort, I appreciate it.