CTD When extracting Workshop addons for a server.

I hope this is the right forum.

Recently I attempted to join a server and judging by the loading bar message, it has me download addons from the workshop in addition to the standard custom content that most servers do. However, a problem I found, when it comes to items I know are rather large, (Such as Metropolice Pack v5, maps, or other similiarly large addons) I CTD (crash to desktop) when the item is finished extracting.

Example of the loading messages.

“Downloading ‘Metropolice Pack’ from workshop”

Alright, that’s fine and all. The issue comes to be the point right below.

“Extracting ‘Metropolice Pack’”

When it gets to that point, most addons I download from the server (Or that I downloaded myself and are required by the server) go by just fine. However like I said, when it comes to larger addons I get a CTD when it gets to the end of the extraction and reads

“Extracted ‘Metropolice Pack’”

Once that happens, it remains for few seconds before I get a CTD with no error whatsoever.

I have redownloaded Gmod, simply uninstalled the folder, deleted select files and verified integrity, as well as simply redownloaded all addons. However the case remains consistent that extracting large addons the server wants me to download from the workshop will CTD me.

The most frustrating about this is instead of relying on the server, I went ahead and downloaded the larger addons myself so that it doesn’t bother me about it. However when it does pick up that I have downloaded said addon and skips that step, it still makes me have to extract the file anyway, which of course crashes me. I have also tried the course of disabling downloading server content, but unfortunately I then receive the issue of it being stuck on ‘Retrieving server data’ before crashing. In regards to that particular problem, I know it’s due to running out of memory (even though I have enough and the game simply remains frozen as the memory on my task manager slowly and painfully trickles down after 20 mins of frozen, which leads me to believe it’s an issue with Gmod leaking memory) however the retrieving server data is irrelevant, as that only happens when completely disabling downloading items from a server (Which is still an issue, but not one that I’m most worried about) it’s a matter of me crashing on reaching the end of extracting something.

If there was perhaps an option to allow custom content, but disable checking for workshop items the server is subscribed to, then that might help. Otherwise I have tried what my rudimentary knowledge has come up with. If anyone can help me at all with this issue, that’d be awesome, because this keeps me from going onto servers that use sizable workshop addons.

OS: Windows XP Professional
Processor: AMD Phenom II X4 945 2.99 GHz
3.25 GB of RAM
NVIDIA GeForce GTX 460

Windows XP is really starting to have problems when running newer applications these days. I would really recommend upgrading as this is most likely the problem

That could very possibly be the case, however I have never once had issues running any newer games due to any OS limitations. I know others have had this same issue in regards to extracting, but nobody really knows what’s going on and tend to blame GMod or the server workshop functionality itself.

I do plan on upgrading at some point in the near future when I can afford it and I’ll definitely post back here when that occurs, but until then I would like to try and exhaust any other possibility.

I have the exact same problem, I to run Windows XP professional. I have searched for ways to fix it ( extracting and retyping it myself) and nothing seems to work. :frowning: i am still searching for a solution but its till has not come up yet.

I FOUND THE SOLUTION EVERYBODY.

This issue has been plaguing me for YEARS, the solution is easy

-open gmod

-click options

-open multiplayer tab

-Set the “When a game server tries to download custom content to your computer” to DO NOT DOWNLOAD ANY CUSTOM FILES.

This will stop the workshop extract process entirely, and allow you to move through easy,

You’re welcome Garrysmod

-TheBloodMaster

But then you can’t download custom content. That ruins the whole purpose.

You’ll still be able to DL them from workshop, and thus there are no issues.

Yeah, like each and every server uses WorkshopDL! :suicide:

FastDL exists too, you know?