Cubemap issue

Hey yall! I’ve got a bit of trouble with my cubemaps. They’ve got checkered reflections and I’ve already tried env_cubemap and typing buildcubemap into the console(then restarting the map), neither of which work and the latter one actually makes the bugged reflections even more obvious. I’ve seen a lot of great work come from this section of the forum, so it seems obvious to me that someone here should know how to fix this problem.

The floor is the only issue:

Thank you for any help you can give me.

You can try a few things here.

  1. Place one cube map roughly 56 units above the floor and select the brush face as the floor using your cursor (point-and-click).

  2. Ensure under the parameters of the .vmt responsible for that texture, the following parameters exist:

“$envmap” “env_cubemap”
“$bumpmap” “path…to…normal…map/texture_name_here”

  1. Once the map is compiled and you are in-game, execute these commands in the following order:

mat_specular 0
buildcubemaps
mat_specular 1
disconnect
sv_cheats 1
mat_reloadallmaterials
sv_cheats 0

  1. Under your video graphics settings, check to determine whether you have shader and texture details set to high.

  2. Reload the map via the console command: “map mapname”
    ex: “map gm_flatgrass”

**Note: **Ensure “r_specular” is set to 1 to enable cubemaps

Note: You can improve the quality of your lightmap shadows by adjusting the lightmap scale to a lower power of 2 (ex: 8)

Let us know if this works out for you or if you notice any changes.

Good luck!

Thanks for responding, I tried them all but they didn’t work. All of my other textures use the cubemaps just fine, except for that one, and the texture .vmt appears ok. Could I have placed it poorly or something?

Just swapped the texture and it worked fine, so it’s gotta be the floor texture. Gonna double check the .vmt.

I can’t find anything wrong with the .vmt.

When you “swapped” the texture, did you simply edit the $basetexture file path or did you replace the $bumpmap file path as well? Check to ensure the normal map .vtf exists in the specified file path.

Does the normal map .vtf have the same image dimensions as the base texture?

Try this out and let me know.

Edit: Does the normal map .vtf have the normal map flag?
See https://developer.valvesoftware.com/wiki/Valve_Texture_Format

Look under “Image Flags”. You will need a program such as vtfedit to determine this for the .vtf file in question.

The image dimensions were the same. By “swap” I meant all I did was change the texture on the brush to ensure it wasn’t the location/lighting/env_cubemap.

The normal flag wasn’t ticked, so I ticked it and tried it out, no dice.

Here’s what it looks like when I use buildcubemap:

[editline]26th July 2012[/editline]

Okay, I “fixed” it by getting rid of the bumpmap. It was causing this bug for some reason.

The bumpmap is missing in that picture.

if you’re using envmapmask and bumpmap together, they don’t work.
you need to embed the mask in the bumpmap’s alpha then put
normalmapalphaenvmapmask 1