Custom blend texture show up as fullbright in hammer.

Yeah, for some reason the texture show up as fullbright in hammer (in shaded textured polygon mode), and it’s also brighter in-game than the textures I use in it (although it’s still shaded).
Here’s the vmt:



"WorldVertexTransition"
{
	"$basetexture" 			"nature/snowfloor002a"
	"$basetexture2" 		"nature/snowwall002a"
	"$blendmodulatetexture" 	"nature/blend_snowfloorwall1_blendmask"
	"$bumpmap" 			"nature/snowfloor002a_normal"
	"$bumpmap2" 			"nature/snowwall002a_normal"
	"$normalmapalphaenvmapmask" 	"1"
	"$normalmapalphaenvmapmask2" 	"1"
	"$envmap" 			"cubemaps/cubemap_icecave01"
	"$surfaceprop" 			"snow"
	"$surfaceprop2" 		"ice"
	"$envmaptint" 			"[0.4 0.4 0.4]"
	"%tooltexture" 			"nature/blend_snowfloorwall1_tool"
}


Any ideas?

Edited: Wow, that’s really nice of you to rate me dumb and then not explain why.

“$envmap” “cubemaps/cubemap_icecave01”

Maybe thats causing it? try setting it to env_cubemap

Nope, that’s just the path to a custom cubemap, doesn’t change anything.

Try disabling one parameter at a time until it works.

Didn’t work either. Tried disabling every parameter except the base textures, seems quite hopeless/fucking stupid now…

Weird. I never get this error. Maybe its some setting in your vtf editor?

That’s the funny thing, those are default Half-Life 2 textures, I’ve only made a custom vmt.

Are you sure they’re not model textures?

Yep. The original textures show up normal in hammer as well.

Try disabling both the bumpmaps (and this: “$normalmapalphaenvmapmask”). I don’t think you can bumpmap displacements (could very well be wrong, but it’s worth a shot.)

Already tried this, and yes, you can bump map displacements (Ep2 caves, for instance).

I hate it when shit just won’t work, no matter what you do…

Shouldn’t this be “LightmappedGeneric”? If not, then please explain what the difference between them is.

WorldVertexTransition is used for blend materials.