Custom particle effect not working.

I get the error message “Attempted to precache unknown particle system “smoketrials”!” and "Attempting to create unknown particle system ‘smoketrials’ " in the console when trying it. It is a muzzle smoke effect produced after firing my custom weapon for Trouble In Terrorist Town. The particle file is included in the particles folder and in particle_manifest.txt with

.

If anyone knows a solution to this please help me. Thanks in advance.

The manifest file is obsolete. You have to use
[LUA]game.AddParticles(“particles/yourparticlefile.pcf”)[/LUA]

both server- and clientside.

Where is that suppose to be added in?

Just put it into a lua-file and throw it into ‘lua/autorun/’.

[EDITLINE]-[/EDITLINE]
You’ll also have to use AddCSLuaFile to make sure the clients receive it as well:
[LUA]
AddCSLuaFile()
game.AddParticles(“particles/yourparticlefile.pcf”)
[/LUA]

Thanks for the fast reply :downs: .

[editline]6th January 2013[/editline]

I have just tried that but it still gives me the same error message :frowning: .

Typo? Check your code, sometimes it’s hard to spot things like this

Thanks for the reply. There was indeed a typo in my weapon qc file but even after fixing it, it still gives me the same error message expect this time its “smoketrails” not “smoketrials” :frowning:

Are you trying to create the effect serverside or clientside?
If you’re creating it clientside, you’ll have to precache it on the server beforehand using PrecacheParticleSystem(“smoketrails”).

I’m creating it cilentside but even after adding that i still get the error message "Attempting to create unknown particle system ‘smoketrials’ " . But the other one doesn’t appear anymore.

Are you sure the name of your particle that you’re trying to display(the one in the .pcf) is smoketrails?

Thanks for the suggestion, but it still gives me the same error message after changing it in the lua file as it is named “smoke_trail” (I checked it using VIDE).

Show us the bit of your code where you’re spawning the effect mate.

Wait thats not lua that’s particles in model.

Oh sorry, the lua file is,

They both need to be called in GM:Initialize as far as I know. You have the right syntax for the functions. They just need to be called server AND client in Initialize.

How do I do that? Do I change the lua code to,

?

Hooks would be better
[lua]hook.Add( “Initialize”, “Initialize particles/smoketrails.pcf”, function()
–Your code here
end)[/lua]

I tried changing the code to

but it still gives me the same error message, I’m not sure if I did right or wrong.
Would you guys like me to upload the files?

Weird, i did the way Silverlan mentioned on my SWEP and it worked.

Also, yes, an upload would be useful.