Custom Sound Files (Both WAV/MP3) are failing to play

I’ve created some custom WAV/MP3 files to play when a player activates them in a SWEP. It’s really just an edit of the Angry Hobo SWEP.

[WARNING] The sounds on the files are loud and may be slightly NSFW
Here’s a .WAV file that comes with the Angry Hobo SWEP. It works fine.

Here’s a .WAV file I’ve encoded @ 44100Hz. It does not work in the swep, nor when using the command ulx playsound weapons/hobo/hoboswep25.wav
The error this creates in my console is [LC ULib ERROR] Received invalid sound

Here’s the previous .WAV encoded into a MP3 @ 44100Hz. It doesn’t work in the swep, nor when played with ulx playsound weapons/hobo/hoboswep25.mp3**
It also gives the error [LC ULib ERROR] Received invalid sound

Just out of curiosity I encoded one of the working .WAV files into a .MP3 @ 44100Hz and tried to play it, and it became unusable in both the swep and when using the command ulx playsound weapons/hobo/hoboswep1.mp3
It throws the error [LC ULib ERROR] Received invalid sound

Here’s a picture of my folder structure

Here’s a picture of the folder structure on my FastDL

Audio recording was done on Teamspeak @ 48000Hz then converted to 44100Hz on audacity.

It’s weapons/hobo/hoboswep25.wav not weapons\hobo\hoboswep25.wav

Apologies, I formatted this thread wrong.
In the script it’s weapons/hobo/hoboswep#.wav / weapons/hobo/hoboswep#.mp3

It has to be a 16-bit stereo (Use audacity)

Here’s how my Audacity settings and exporting is setup. It still won’t play in the swep, or with the command.
https://imgrush.com/-9ga5UA3oeu1

Project Rate: 44100
sample format: 32-bit float
mono

those are my settings for mp3’s and they work all the time.

Those settings are now working, thank you!