Custom soundscape... only working for me? (It's packed in)

I have a custom soundscape packed into a map of mine.

I don’t have the script anywhere else, EXCEPT the bsp file.

I can hear all the sounds fine, but I tested with about 4 people and they can’t hear the sounds UNLESS they type playsoundscape (custom soundscape name).

So the soundscape is there, but the game isn’t playing it for them for some reason, but it is for me.

I honestly can’t even begin to think how this happens.

Also:



"Rooftop"// Wind
{

	"playrandom"
	{
		"volume"	"0.06,.1.2"
		"time"		"10.0, 20.0"
		"pitch"		"90,130"
		"position"	"random"
		"rndwave"
		{

			"wave" "ambient\levels\streetwar\city_battle13.wav"
			"wave" "ambient\levels\streetwar\city_battle11.wav"
			"wave" "ambient\levels\streetwar\city_battle11.wav"		
			"wave" "ambient\levels\streetwar\city_battle4.wav"
			"wave" "ambient\levels\streetwar\strider_distant1.wav"

			
				
		}
	}

	         "dsp"   "1" 
     

         "playlooping" 
         { 
                "volume"       ".3" 
                "pitch"        "100" 
                "wave"         "ambient\wind\wind_rooftop1.wav" 
         }
 	 "playlooping" 
         { 
                "volume"       ".1" 
                "pitch"        "50" 
                "wave" "ambient\explosions\battle_loop1.wav"
         }	

}



"Inbuilding"// Inside building
{

	"playrandom"
	{
		"volume"	"0.2,.3"
		"time"		"10.0, 20.0"
		"pitch"		"90,130"
		"position"	"random"
		"rndwave"
		{

			"wave" "ambient\materials\cartrap_rope2.wav"		
			"wave" "ambient\materials\creaking.wav"
			"wave" "ambient\materials\metal_stress5.wav"

			
				
		}
	}

	         "dsp"   "1" 
     

         "playlooping" 
         { 
                "volume"       ".4" 
                "pitch"        "100" 
                "wave"         "ambient\atmosphere\quiet_cellblock_amb.wav" 
         }

}


To confirm, the soundscape file is named “soundscapes_<mapname>.txt” and under the “…/scripts/” directory within the BSP?

What game is running the map?

Garrysmod.

And yeah, it’s the soundscapes_mapname.txt, and it’s packed specifically under scripts.

It plays for me, but nobody else unless they use the command.

I don’t have it saved anywhere in my garrysmod folder, only in the bsp.

Do the sounds work if the map is loaded with another game?

What if the script is extracted from the BSP and placed within the game directory as a stand-alone file? If this works, might consider distributing the map as an addon.

Lastly, this may be worth a try even though it was intended for another game.